This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 427439 - ata_piix isn't picked up
ata_piix isn't picked up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 15:13 EST by David Zeuthen
Modified: 2013-03-05 22:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 12:43:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tree /sys (307.75 KB, text/plain)
2008-01-03 15:15 EST, David Zeuthen
no flags Details

  None (edit)
Description David Zeuthen 2008-01-03 15:13:49 EST
if I use --with=ata_piix then it works.. details here

# cat /etc/fstab
LABEL=/12               /                       ext3    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda6         swap                    swap    defaults        0 0

# ls -l /dev/disk/by-label |grep "12"
lrwxrwxrwx 1 root root 10 2008-01-03 15:01 \x2f12 -> ../../sda5

# /lib/udev/vol_id /dev/sda5
ID_FS_USAGE=filesystem
ID_FS_TYPE=ext3
ID_FS_VERSION=1.0
ID_FS_UUID=25f87c9d-5ae8-4a5d-b5ac-214eff9cdce2
ID_FS_UUID_ENC=25f87c9d-5ae8-4a5d-b5ac-214eff9cdce2
ID_FS_LABEL=/12
ID_FS_LABEL_ENC=\x2f12
ID_FS_LABEL_SAFE=12

# uname -a
2.6.24-0.133.rc6.git8.fc9
Linux oneill 2.6.24-0.133.rc6.git8.fc9 #1 SMP Wed Jan 2 18:40:29 EST 2008 i686
i686 i386 GNU/Linux

# mkinitrd -v -f /boot/initrd-2.6.24-0.133.rc6.git8.fc9.img Creating initramfs
Found root device /sys/block/sda/sda5 for LABEL=/12
Looking for driver for device /sys/block/sda/sda5
Looking for driver for device LABEL=/12
Looking for driver for device /sys/block/sda/sda6
Using modules:  ehci-hcd ohci-hcd uhci-hcd ext3
Building initrd in /tmp/initrd.us8250
/sbin/nash -> /tmp/initrd.us8250/bin/nash
  /usr/lib/libnash.so.6.0.27 -> /tmp/initrd.us8250/usr/lib/libnash.so.6.0.27
    /lib/libdevmapper.so.1.02 -> /tmp/initrd.us8250/lib/libdevmapper.so.1.02
      /lib/libselinux.so.1 -> /tmp/initrd.us8250/lib/libselinux.so.1
        /lib/libdl.so.2 -> /tmp/initrd.us8250/lib/libdl.so.2
          /lib/libdl-2.7.90.so -> /tmp/initrd.us8250/lib/libdl-2.7.90.so
            /lib/i686/nosegneg/libc.so.6 -> /tmp/initrd.us8250/lib/libc.so.6
              /lib/i686/nosegneg/libc-2.7.90.so ->
/tmp/initrd.us8250/lib/i686/nosegneg/libc-2.7.90.so
                /lib/ld-2.7.90.so -> /tmp/initrd.us8250/lib/ld-2.7.90.so
      /lib/libsepol.so.1 -> /tmp/initrd.us8250/lib/libsepol.so.1
    /usr/lib/libparted-1.8.so.6 -> /tmp/initrd.us8250/usr/lib/libparted-1.8.so.6
      /usr/lib/libparted-1.8.so.6.0.0 ->
/tmp/initrd.us8250/usr/lib/libparted-1.8.so.6.0.0
        /lib/libuuid.so.1 -> /tmp/initrd.us8250/lib/libuuid.so.1
          /lib/libuuid.so.1.2 -> /tmp/initrd.us8250/lib/libuuid.so.1.2
    /lib/libblkid.so.1 -> /tmp/initrd.us8250/lib/libblkid.so.1
      /lib/libblkid.so.1.0 -> /tmp/initrd.us8250/lib/libblkid.so.1.0
    /lib/libpopt.so.0 -> /tmp/initrd.us8250/lib/libpopt.so.0
      /lib/libpopt.so.0.0.0 -> /tmp/initrd.us8250/lib/libpopt.so.0.0.0
    /lib/libresolv.so.2 -> /tmp/initrd.us8250/lib/libresolv.so.2
      /lib/libresolv-2.7.90.so -> /tmp/initrd.us8250/lib/libresolv-2.7.90.so
    /usr/lib/libdhcp-1.99.so.1 -> /tmp/initrd.us8250/usr/lib/libdhcp-1.99.so.1
      /usr/lib/libdhcp-1.99.so.1.0.2 ->
/tmp/initrd.us8250/usr/lib/libdhcp-1.99.so.1.0.2
        /usr/lib/libdhcp4client-3.1.0.so.0 ->
/tmp/initrd.us8250/usr/lib/libdhcp4client-3.1.0.so.0
        /usr/lib/libdhcp6client-1.0.so.2 ->
/tmp/initrd.us8250/usr/lib/libdhcp6client-1.0.so.2
          /usr/lib/libdhcp6client-1.0.so.2.0.2 ->
/tmp/initrd.us8250/usr/lib/libdhcp6client-1.0.so.2.0.2
        /usr/lib/libnl.so.1 -> /tmp/initrd.us8250/usr/lib/libnl.so.1
          /usr/lib/libnl.so.1.0-pre8 -> /tmp/initrd.us8250/usr/lib/libnl.so.1.0-pre8
            /lib/i686/nosegneg/libm.so.6 -> /tmp/initrd.us8250/lib/libm.so.6
              /lib/i686/nosegneg/libm-2.7.90.so ->
/tmp/initrd.us8250/lib/i686/nosegneg/libm-2.7.90.so
    /lib/libglib-2.0.so.0 -> /tmp/initrd.us8250/lib/libglib-2.0.so.0
      /lib/libglib-2.0.so.0.1500.0 -> /tmp/initrd.us8250/lib/libglib-2.0.so.0.1500.0
    /lib/libgcc_s.so.1 -> /tmp/initrd.us8250/lib/libgcc_s.so.1
      /lib/libgcc_s-4.1.2-20071124.so.1 ->
/tmp/initrd.us8250/lib/libgcc_s-4.1.2-20071124.so.1
  /usr/lib/libbdevid.so.6.0.27 -> /tmp/initrd.us8250/usr/lib/libbdevid.so.6.0.27
/sbin/modprobe -> /tmp/initrd.us8250/bin/modprobe
/sbin/rmmod -> /tmp/initrd.us8250/bin/rmmod
Looking for deps of module ehci-hcd
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
Looking for deps of module ext3: mbcache jbd 
Looking for deps of module ehci-hcd
Looking for deps of module ext3: mbcache jbd 
Looking for deps of module jbd
Looking for deps of module mbcache
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
copy from
`/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/drivers/usb/host/ehci-hcd.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/ehci-hcd.ko' [elf32-i386]
copy from `/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/fs/ext3/ext3.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/ext3.ko' [elf32-i386]
copy from `/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/fs/jbd/jbd.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/jbd.ko' [elf32-i386]
copy from `/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/fs/mbcache.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/mbcache.ko' [elf32-i386]
copy from
`/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/drivers/usb/host/ohci-hcd.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/ohci-hcd.ko' [elf32-i386]
copy from
`/lib/modules/2.6.24-0.133.rc6.git8.fc9/kernel/drivers/usb/host/uhci-hcd.ko'
[elf32-i386] to
`/tmp/initrd.us8250/lib/modules/2.6.24-0.133.rc6.git8.fc9/uhci-hcd.ko' [elf32-i386]
Adding module ehci-hcd
Adding module ohci-hcd
Adding module uhci-hcd
Adding module ext3
This initrd uses dynamic shared objects.
Adding dynamic linker configuration files.
/etc/ld.so.conf -> /tmp/initrd.us8250/etc/ld.so.conf
/etc/ld.so.conf.d/atlas-i386.conf ->
/tmp/initrd.us8250/etc/ld.so.conf.d/atlas-i386.conf
/etc/ld.so.conf.d/xulrunner-32.conf ->
/tmp/initrd.us8250/etc/ld.so.conf.d/xulrunner-32.conf
/etc/ld.so.conf.d/qt-i386.conf -> /tmp/initrd.us8250/etc/ld.so.conf.d/qt-i386.conf
/etc/ld.so.conf.d/freetype-freeworld-i386.conf ->
/tmp/initrd.us8250/etc/ld.so.conf.d/freetype-freeworld-i386.conf
/etc/ld.so.conf.d/mysql-i386.conf ->
/tmp/initrd.us8250/etc/ld.so.conf.d/mysql-i386.conf
Running ldconfig
Comment 1 David Zeuthen 2008-01-03 15:14:28 EST
# rpm -q mkinitrd
mkinitrd-6.0.27-1.fc9
Comment 2 David Zeuthen 2008-01-03 15:15:58 EST
Created attachment 290777 [details]
tree /sys
Comment 3 Eric Paris 2008-01-03 15:49:33 EST
adding the block device driver to modprobe.conf should also fix the problem. 
but i think mkinitrd is supposed to figure it out itself....
Comment 4 Benjamin Lewis 2008-01-03 18:27:42 EST
Just a thought, since I've seen something similar to this before, try replacing
the LABEL=/ in your fstab with the actual device name (i.e. /dev/sda1).
Comment 5 David Zeuthen 2008-01-03 18:33:38 EST
(In reply to comment #4)
> Just a thought, since I've seen something similar to this before, try replacing
> the LABEL=/ in your fstab with the actual device name (i.e. /dev/sda1).

That's not the problem; anyway pjones said that he've fixed this already (he
ssh'ed into my box) and a build is forthcoming...
Comment 6 David Zeuthen 2008-01-05 13:27:27 EST
Peter, any chance of getting this fix into Rawhide? Thanks.
Comment 7 David Zeuthen 2008-01-08 18:46:55 EST
Peter: Ping
Comment 8 Peter Jones 2008-01-09 12:43:39 EST
Should be fixed in 6.0.28-1.fc9 .
Comment 9 David Zeuthen 2008-01-11 21:58:30 EST
6.0.28-1.fc9 works for me. Thanks.

Note You need to log in before you can comment on or make changes to this bug.