Bug 427453 - nautilus pretends not to know what "Computer" is
nautilus pretends not to know what "Computer" is
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 17:08 EST by Michal Jaegermann
Modified: 2015-03-03 17:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 11:04:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-03 17:08:51 EST
Description of problem:

A click on a "Computer" desktop icon, or equivalent operations
from an icon menu, brings an alert with the following:

Couldn't display "computer:///".
There is no application installed for this file type

and that is the end of it.

Version-Release number of selected component (if applicable):
nautilus-2.21.1-2.fc9

How reproducible:
always
Comment 1 Joachim Frieben 2008-01-04 16:52:45 EST
I'm seeing the same here, and it seems like this is related to other issues
like being unable to drag drive or folder icons like "Computer" or "Trash"
across the desktop.
Comment 2 antonio montagnani 2008-01-05 15:48:37 EST
same here....as per the comment of Joachim, I add also same problem with DVD...
Comment 3 Lubomir Kundrak 2008-01-05 21:03:26 EST
What happens when you do the following in terminal?

$ gnomevfs-ls computer:///
Comment 4 Michal Jaegermann 2008-01-05 21:31:29 EST
On my machine it prints (modulo mangling by bugzilla):

Filesystem.desktop              (Regular, application/x-desktop)        size 0
mode 0444
Network.desktop         (Regular, application/x-desktop)        size 0  mode 0444
CD-RW%2FDVD%C2%B1RW%20Drive.drive               (Regular, application/x-desktop)
           size 0   mode 0444
Floppy%20Drive.drive            (Regular, application/x-desktop)        size 0
mode 0444
Comment 5 Matthias Clasen 2008-01-05 22:04:38 EST
This is being worked on. gvfs doesn't have a computer:// implementation yet
Comment 6 MASAO TAKAHASHI 2008-01-07 22:54:37 EST
give me a workaround.
Comment 7 Joachim Frieben 2008-01-08 14:21:28 EST
Fixed after upgrading to nautilus-2.21.2-1.fc9 plus gvfs-0.1.1-1.fc9
and glib2-2.15.1-1.fc9. Dragging drive/folder icons across the desktop
is also possible again.
Comment 8 antonio montagnani 2008-01-09 01:33:49 EST
also glib2-devel should be upgraded otherwise some dependencies problems.....
Comment 9 Michal Jaegermann 2008-01-09 15:18:18 EST
Installing nautilus-2.21.2-1.fc9, and other related updates, had
really curious effects.

"Computer" window did open but after clicking in it on an icon
which claimed to belong to CD I got the following alert:

Couldn't display "computer:///CD-RW%5CDVD%C2%B1RW%20Drive.drive".
There is no application installed for this file type

After this alert was acked the whole nautilus promptly crashed,
taking with it all its windows and icons, and stayed that way
on subsequent re-logins to new sessions.  Luckily a removal
of the whole old accumulated ~/.nautilus/ tree before an attempt
to login once more apparently solved that one.

Icons for removable media are still "generic" although media are
auto-mounted and picking up "Eject" or "Unmount Volume" from an
icon menu _on a desktop_ does what is expected.  This is not the
case if I am trying the same action on corresponding icons in
a "Computer" window.  That results in the following:
  - all nautilus provided icons and windows vanish from a desktop
  - nautilus apparently restarts and restores icons and opens, the
    only one, window showing my home directory (there was one,
    but "Computer", nautilus window open at the beginning)
  - media which I attempted to unmount/eject are still there and
    a corresponding, generic, icon appears on a desktop

Also on one try I got an alert telling me that only root can unmount
my CD but typing 'eject' in a terminal window unmounted and ejected
that CD without any further fuss.  Boggles ...
Comment 10 Anthony Thyssen 2008-01-14 01:37:40 EST
I did not want to even try to install a FC9 nautilus to fix this problem so I
decided to try something less drastic....

I reinstalled the existing version of nautilus!!!

I when to my nearby YUM repository, located the FC8 version of nautilus (same as
what is currently installed, no upgrades for it as yet), and downloaded that RPM.

I then re-installed it...
    rpm -Uhv --replacepkgs nautilus-2.20.0-6.fc8.i386.rpm

Logout, Login and hey my nautilus was working again.   file://home/...  was
usable, as was all the links in computer://  and preview icons was being
generated again.

this was the simplist fix I have yet had to this problem,  My setup was
retained, including my 'open with' preferences. previously I have tried a lot of
such fixes, from removing all my gnome 'dot' directories, to complete
re-installs of the machines OS.

Nautilus appears to be far to fragile in its file to action determination as
this has now happened to me about half a dozen times in everythinf from FC2 to
Ubuntu, and other linux setups.

This is NOT a good thing for a supposed "desktop for computer newbies". Problems
such as this should idealy be self correcting, not requiring hit or miss fixes
such as I see ,and continue to see in my gogle searches on this problem.
Comment 11 Michal Jaegermann 2008-02-01 15:14:15 EST
The current version of rawhide nautilus, i.e. nautilus-2.21.90-1.fc9,
seems to behave on a very basic level (while ignoring configuration
flags) but, as comment #10 says, all of this feels really fragile
and is an issue.
Comment 12 Matthias Clasen 2008-03-17 11:04:03 EDT
I'll declare this fixed now. Nautilus 2.22.0 has working computer:// support.
Please file new bugs for possible remaining issues.

Note You need to log in before you can comment on or make changes to this bug.