Bug 427506 - Provide sane #description for mcstrans, restorecond, setroubleshoot
Provide sane #description for mcstrans, restorecond, setroubleshoot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 05:29 EST by Linus Walleij
Modified: 2008-01-07 23:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 23:01:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Walleij 2008-01-04 05:29:44 EST
As it says, these services/daemons:

mcstrans
restorecond
setroubleshoot

are still set to start automatically even if you chose to disable SELinux during
install. I see no immediate reason for, and endusers may be confused as to why
these services/daemons are still enabled (atleast I was).

Bug initated from disussion on fedora-devel following bug 249204.
Comment 1 Linus Walleij 2008-01-04 17:40:07 EST
Since it turns out all of these services will auto-terminate
if SELinux is disabled, I rephrase the bug so that it now cosiders
a system-config-services usability issue, the

# description: nnnn

fields in /etc/init.d/{mcstrans|restorecond|setroubleshoot}
are too simplistic, and as this is all the user of s-c-s sees,
need to be expanded to include information that indicates that the
user do not need to disable this service if they're not using SELinux,
since it will auto-terminate.

I'm making up patches, hold on.
Comment 2 Chris Lumens 2008-01-07 23:01:30 EST
This needs to be filed against the individual packages that provide those
programs, then.  Thanks for the bug report.  You can attach your patches to new
bugs filed against those components.

Note You need to log in before you can comment on or make changes to this bug.