Bug 427518 - ACPI video driver should validate brightness level before setting it via _BCM
ACPI video driver should validate brightness level before setting it via _BCM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2008-01-04 06:45 EST by Julian Sikorski
Modified: 2008-02-11 17:39 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.23.15-137.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 17:39:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch in question, in case someone wants to test (2.85 KB, text/plain)
2008-01-09 14:36 EST, Chuck Ebbert
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 9277 None None None Never
Linux Kernel 9614 None None None Never

  None (edit)
Description Julian Sikorski 2008-01-04 06:45:03 EST
Description of problem:
In the current situation, sliding the brightness bar in gnome-power-manager
causes a lot of screen flickering, since it goes to 100 % for invalid values.
Upstream bug report contains a working fix, which applies cleanly against
kernel-2.6.24-0.133.rc6.git8.fc9. It would be nice if the fix could be
backported to F8 kernel as well.
Comment 1 Jon Stanley 2008-01-04 10:55:21 EST
Adding ACPI metadata.
Comment 2 Julian Sikorski 2008-01-09 07:39:12 EST
Patch has now been merged to acpi test branch.
Comment 3 Chuck Ebbert 2008-01-09 14:36:33 EST
Created attachment 291191 [details]
the patch in question, in case someone wants to test
Comment 4 Julian Sikorski 2008-01-12 04:35:15 EST
So, are there any chances this patch hits Fedora kernel before it gets merged
upstream?
Comment 5 Julian Sikorski 2008-01-12 04:42:47 EST
CCing upstream submitter.
Comment 6 Danny Baumann 2008-01-12 07:26:47 EST
The patch in comment #3 works fine for me, and I'd also appreciate it being
merged to the Fedora kernels. g-p-m backlight management is just unusable as it
is now for ACPI video driver users.
Comment 7 Julian Sikorski 2008-02-02 11:03:11 EST
The patch has been updated, new one is even better. It would be very cool if
this patch could be applied to Fedora kernel along with the one mentioned in
kernel bug #9614. These two greatly improve the backlight experience.
Comment 8 Chuck Ebbert 2008-02-05 19:50:08 EST
Fixed in 2.6.23.14-132
Comment 9 Julian Sikorski 2008-02-06 04:27:46 EST
The backlight issues are fixed, thank you. Not sure if this bug should be
closed, or stay open until the fixed kernel hits the repositories.
Comment 10 Fedora Update System 2008-02-10 22:34:14 EST
kernel-2.6.23.15-137.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-02-11 17:39:00 EST
kernel-2.6.23.15-137.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.