This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 427529 - Please update to upstream version 2.6
Please update to upstream version 2.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libconfuse (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 427530
  Show dependency treegraph
 
Reported: 2008-01-04 09:13 EST by Hans Ulrich Niedermann
Modified: 2008-02-04 10:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 10:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Apply patch in F-8/ directory: libconfuse-2.6-0.2 (2.37 KB, patch)
2008-01-21 11:10 EST, Hans Ulrich Niedermann
no flags Details | Diff

  None (edit)
Description Hans Ulrich Niedermann 2008-01-04 09:13:42 EST
At the time of this writing libconfuse-2.5-3 is the newest package in F-8 and
rawhide.

http://www.nongnu.org/confuse/ says that the new libconfuse-2.6 release is to be
found at http://bzero.se/confuse/ instead of at
http://download.savannah.nongnu.org/releases/confuse/ (for some reason).
Comment 1 Jarod Wilson 2008-01-04 09:49:23 EST
Hrm... Two issues with the new version...

1) it doesn't actually build for me

2) the license changed

The first is definitely a problem. At a glance, looks like probably just a
compiler flag that needs tweaking so we don't treat warnings as errors. The
second just needs a bit of research to make sure the new license conditions are
okay for Fedora.


Snippet from build failure:

gcc -DLOCALEDIR=\"/usr/share/locale\" -DHAVE_CONFIG_H -I. -I. -I.. -Wall -Werror
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT confuse.lo -MD -MP -MF
.deps/confuse.Tpo -c confuse.c  -fPIC -DPIC -o .libs/confuse.o
 gcc -DLOCALEDIR=\"/usr/share/locale\" -DHAVE_CONFIG_H -I. -I. -I.. -Wall
-Werror -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT lexer.lo -MD
-MP -MF .deps/lexer.Tpo -c lexer.c  -fPIC -DPIC -o .libs/lexer.o
cc1: warnings being treated as errors
lexer.c: In function 'cfg_yylex':
lexer.l:270: warning: ignoring return value of 'fwrite', declared with attribute
warn_unused_result
make[2]: *** [lexer.lo] Error 1
Comment 2 Hans Ulrich Niedermann 2008-01-21 11:10:06 EST
Created attachment 292382 [details]
Apply patch in F-8/ directory: libconfuse-2.6-0.2

This is how I would do it... and it seems to build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=362349

I have not checked that any of the libconfuse dependencies work with this
package, though.
Comment 3 Jarod Wilson 2008-02-04 10:25:43 EST
ISC appears to be the correct value for the License: field, and its just fine
with legal. Committing and building for rawhide shortly...
Comment 4 Jarod Wilson 2008-02-04 10:42:00 EST
Built for rawhide, building for F-8 now.

Note You need to log in before you can comment on or make changes to this bug.