Bug 42753 - usb-ohci on alpha: module complains about no interrupt
usb-ohci on alpha: module complains about no interrupt
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 18:38 EDT by Dries Verachtert
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 19:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dries Verachtert 2001-05-29 18:38:36 EDT
Description of Problem:
usb-ohci module doesn't work anymore. When i try to modprobe the module, i get:
[root@garfield root]# modprobe usb-ohci
/lib/modules/2.4.3-7/kernel/drivers/usb/usb-ohci.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including 
invalid IO or IRQ parameters
/lib/modules/2.4.3-7/kernel/drivers/usb/usb-ohci.o: insmod 
/lib/modules/2.4.3-7/kernel/drivers/usb/usb-ohci.o failed
/lib/modules/2.4.3-7/kernel/drivers/usb/usb-ohci.o: insmod usb-ohci failed

In /var/log/messages:
May 30 00:26:08 garfield kernel: usb-ohci.c: found OHCI device with no IRQ 
assigned. check BIOS settings!

How Reproducible:
always

Steps to Reproduce:
1. 'modprobe usb-ohci'

Actual Results:
warning about no interrupt

Expected Results:
module loaded in kernel

Additional Information:
Loading of the usb-ohci module worked perfect in older rawhide 2.4.x kernels. I'm 
not sure but i think from 2.4.3, the usb-ohci driver doesn't work anymore. There is 
nothing changed in the BIOS. This problem also exists on suse and debian with 
kernels >= 2.4.3 on this system.
This system is a MiataGL, alpha PWS 500a.
The following information can be found in /proc/pci about the usb:
  Bus  0, device   7, function  3:
    USB Controller: Contaq Microsystems 82c693 (#4) (rev 0).
      Master Capable.  Latency=32.
      Non-prefetchable 32 bit memory at 0xa080000 [0xa080fff]

This worked in older rawhide kernels without a problem. For example: usbview 
showed a connected Kodak DC3400 camera. For some reason, the usb-ohci 
doesn't have an interrupt anymore.
Comment 1 Phil Copeland 2001-05-29 19:06:50 EDT
Oddly enough something I was writing earlier......

http://ftp.uk.linux.org/pub/linux/redhat/alpha/Decodeing-oops-on-alpha.howto.html

Shows exactly where this all goes horribly wrong
I dunno if a fix will be available shortly though 8/

Strictly speaking, I'm betting this is a dupicate of 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=39111

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.