Bug 427545 - delete doesn't desensitize on guest shutdown
delete doesn't desensitize on guest shutdown
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On: 236824
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 11:12 EST by Cole Robinson
Modified: 2009-12-14 16:10 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream cset 694, change delete sensitivity on guest shutdown. (1.07 KB, patch)
2008-04-15 10:15 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Cole Robinson 2008-01-04 11:12:55 EST
+++ This bug was initially created as a clone of Bug #236824 +++

If you right click on a guest and click shutdown, delete stays not sensitive. 
You have to click to another guest and then back to be able to delete the guest

-- Additional comment from bugzilla@redhat.com on 2007-07-24 22:09 EST --
change QA contact

-- Additional comment from berrange@redhat.com on 2007-09-27 17:07 EST --
Fixed in virt-manger-0.5.0 or later.
Comment 1 RHEL Product and Program Management 2008-01-04 11:14:40 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Cole Robinson 2008-01-17 12:54:08 EST
We've rebased to virt-manager 0.5.3, which contains the fix for this bug:

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-1.el5                  dist-5E-qu-candidate  berrange
Comment 5 Gurhan Ozen 2008-04-14 23:39:01 EDT
I have verified that the functionality of the button works as expected, yet the
button still stays either focused or grayed out from the previous phase, i.e.
doesn't get grayed out when the guest is started or doesn't get focus when the
guest is shutdown. Is that fixable? 

Comment 6 Cole Robinson 2008-04-15 10:00:23 EDT
Yeah, unfortunately this was fixed around version 0.5.0, but then regressed
around 0.5.3, which is what was pulled into rhel5. This has been re-fixed
upstream though so i'll pull down that cset. Thanks!
Comment 7 Cole Robinson 2008-04-15 10:15:13 EDT
Created attachment 302460 [details]
Upstream cset 694, change delete sensitivity on guest shutdown.
Comment 8 Gurhan Ozen 2008-04-17 17:45:23 EDT
(In reply to comment #7)
> Created an attachment (id=302460) [edit]
> Upstream cset 694, change delete sensitivity on guest shutdown.
> 

Hey Cole, 
Yes, this patch works fine. Is it possible for you to do another spin with this
patch in?

Thanks.

Comment 10 Cole Robinson 2008-04-18 10:50:57 EDT
comment #8, i'll try.

To summarize, I thought this was fixed by the rebase, but it actually wasn't
since this issue had also regressed upstream. The patch in comment #7 has been
upstream in some form for over 6 months and has little chance of causing other
problems. This is just another issue of polish, but it is pretty prevalent so I
think we should pull this in for 5.2.
Comment 11 Gurhan Ozen 2008-04-18 16:29:49 EDT
(In reply to comment #10)
> comment #8, i'll try.
> 
> To summarize, I thought this was fixed by the rebase, but it actually wasn't
> since this issue had also regressed upstream. The patch in comment #7 has been
> upstream in some form for over 6 months and has little chance of causing other
> problems. This is just another issue of polish, but it is pretty prevalent so I
> think we should pull this in for 5.2.
  
   Sure:) I am changing the status back to ASSIGNED, so that this can be
discussed in April 22nd rhel meeting. 

Comment 13 Cole Robinson 2008-04-22 12:30:49 EDT
Built into virt-manager-0.5.3-8

$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-8.el5                  dist-5E-qu-candidate  crobinso
Comment 16 errata-xmlrpc 2008-05-21 13:28:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html

Note You need to log in before you can comment on or make changes to this bug.