Bug 427584 - Selinux is preventing access to /var/run/nscd/socket
Selinux is preventing access to /var/run/nscd/socket
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 16:38 EST by George
Modified: 2008-04-07 22:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 22:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the log requested by the tech (2.40 MB, text/plain)
2008-03-19 17:03 EDT, George
no flags Details

  None (edit)
Description George 2008-01-04 16:38:29 EST
Description of problem:

SELinux is preventing /usr/sbin/setsebool (semanage_t) "connectto" to
/var/run/nscd/socket (initrc_t).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2008-01-05 04:30:59 EST
This looks like you have nscd running as initrc_t?  Which would be wrong.  You
could have a labeling problem.

ps -eZ | grep nscd

To fix labeling problems you can execute 

touch /.autorelabel; reboot

Please attach the avc messages from /var/log/audit/audit.log

ausearch -m avc  

will gather them
Comment 2 George 2008-03-19 17:03:48 EDT
Created attachment 298591 [details]
This is the log requested by the tech
Comment 3 Daniel Walsh 2008-03-19 17:22:37 EDT
Looks like nscd is mislabeled.

# matchpathcon /usr/sbin/nscd
/usr/sbin/nscd	system_u:object_r:nscd_exec_t:s0

If it does not have this label

# restorecon /usr/sbin/nscd
# service nscd restart

Should fix it.

Note You need to log in before you can comment on or make changes to this bug.