Bug 427600 - dovecot no longer runs on x86-64
dovecot no longer runs on x86-64
Status: CLOSED DUPLICATE of bug 253363
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dovecot (Show other bugs)
5.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Tomas Janousek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 22:39 EST by Rik van Riel
Modified: 2008-01-05 07:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 07:22:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2008-01-04 22:39:39 EST
Description of problem:

The default login_process_size for dovecot is 32MB.  

This is no longer enough on x86-64, where dovecot's imap-login crashes while
trying to mmap /lib64/libsepol.so.1.

Version-Release number of selected component (if applicable):

dovecot-1.0-1.2.rc15.el5

How reproducible:

Try to use dovecot on x86-64.

Additional info:

Raising the limit to something large makes dovecot work again.  However, a
package update does not override old defaults in a config file the user edited.  

We will probably need to increase the default limit to 128MB, so a system
upgrade does not suddenly break dovecot for existing users.
Comment 1 Tomas Janousek 2008-01-05 07:22:13 EST

*** This bug has been marked as a duplicate of 253363 ***

Note You need to log in before you can comment on or make changes to this bug.