Bug 427621 - Installing firefox 3b2 package -> /usr/lib/xulrunner-1.9pre/extensions: No such file or directory
Summary: Installing firefox 3b2 package -> /usr/lib/xulrunner-1.9pre/extensions: No su...
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-05 15:24 UTC by sangu
Modified: 2008-01-07 17:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 17:33:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sangu 2008-01-05 15:24:47 UTC
Description of problem:
rpm -ihv firefox-3.0-0.beta2.7.fc9.i386.rpm 
Preparing...                ########################################### [100%]
   1:firefox                ########################################### [100%]
/var/tmp/rpm-tmp.33915: line 11: cd: /usr/lib/xulrunner-1.9pre/extensions: No
such file or directory

And needless directory was created.
$ls /\{fda00e13-8c62-4f63-9d19-d168115b11ca\}/
chrome  chrome.manifest  install.rdf
Version-Release number of selected component (if applicable):
3.0-0.beta2.7.fc9

How reproducible:
always

Steps to Reproduce:
1. Install firefox
2.
3.
  
Actual results:


Expected results:


Additional info:
xulrunner-1.9-0.beta2.6.fc9
$ rpm -ql xulrunner | grep xulrunner-1.9pre/extensions

Comment 1 Christopher Aillon 2008-01-07 17:33:14 UTC
XULRunner by design does not ship with an extensions or plugin directory.  This
is a conscious choice by upstream and not one we're going to change. 
Extensions/plugins should be provided by either of: the system[1], the XR app
(e.g. firefox) or the user's profile, not xulrunner itself.

[1] this does not work just yet but I am working on this in a separate bug.


Note You need to log in before you can comment on or make changes to this bug.