Bug 427622 - chmsee crashes with xulrunner
chmsee crashes with xulrunner
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: chmsee (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Yijun Yuan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-05 10:55 EST by Yijun Yuan
Modified: 2008-05-31 22:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 03:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy dump (7.88 KB, text/plain)
2008-03-04 02:08 EST, Yijun Yuan
no flags Details
stack trace with gdb, "thread apply all bt" and "bt full" (8.74 KB, text/plain)
2008-03-04 02:18 EST, Yijun Yuan
no flags Details
chmsee patch (681 bytes, patch)
2008-04-24 12:30 EDT, Martin Stransky
no flags Details | Diff

  None (edit)
Description Yijun Yuan 2008-01-05 10:55:42 EST
Description of problem:
Cannot build programs depending on xulrunner with gcc-4.3 because of several
redefined macros in the header

Version-Release number of selected component (if applicable):
xulrunner-1.9-0.beta2.6.fc9

How reproducible:
every time

Steps to Reproduce:
1. build chmsee which depends on xulrunner, with gcc-4.3
2.
3.
  
Actual results:
http://sunsite.mff.cuni.cz/rawhide20071220-gcc43/redefined/chmsee-1.0.0-1.34.fc9.log

Expected results:
clean build

Additional info:
https://www.redhat.com/archives/fedora-devel-list/2008-January/msg00438.html
Comment 1 Martin Stransky 2008-02-29 09:32:10 EST
Taking the bug.
Comment 2 Yijun Yuan 2008-02-29 09:54:01 EST
now chmsee builds fine in koji, though it crashes and I don't know how to fix
that :(
could you please help?
Comment 3 Martin Stransky 2008-02-29 10:03:35 EST
I expect it's because of wrong path to mozilla. Can you please attach a backtace
of that crash?
Comment 4 Yijun Yuan 2008-03-04 02:08:54 EST
Created attachment 296705 [details]
bug-buddy dump
Comment 5 Yijun Yuan 2008-03-04 02:18:04 EST
Created attachment 296706 [details]
stack trace with gdb, "thread apply all bt" and "bt full"
Comment 6 Martin Stransky 2008-04-24 12:30:32 EDT
Created attachment 303660 [details]
chmsee patch

This patch fixes the chmsee crash after start. It uses the libdir variable for
gtkmozembed instead of the -L library path.
Comment 7 Martin Stransky 2008-04-29 06:50:12 EDT
Shall I check in the patch and rebuild the package?
Comment 8 Yijun Yuan 2008-04-29 08:02:00 EDT
already rebuilt in F-9, has dependency problem in F-10
Comment 9 Martin Stransky 2008-05-06 03:44:22 EDT
Okay. Moving to chmsee.
Comment 10 Fedora Update System 2008-05-31 22:44:14 EDT
chmsee-1.0.0-2.37.fc9 has been submitted as an update for Fedora 9

Note You need to log in before you can comment on or make changes to this bug.