Bug 427657 - on-board hda-intel fails when PCI C-media audio card present.
on-board hda-intel fails when PCI C-media audio card present.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 06:06 EST by Pawel Salek
Modified: 2008-01-16 15:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 15:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Full dmesg (22.92 KB, text/plain)
2008-01-06 06:06 EST, Pawel Salek
no flags Details
output of /sbin/lspci (1.67 KB, text/plain)
2008-01-06 06:08 EST, Pawel Salek
no flags Details

  None (edit)
Description Pawel Salek 2008-01-06 06:06:16 EST
Description of problem:
I have an on-board hda-intel compatible audio. When I insert a PCI C-Media
CM8738 sound card, the hda-intel module fails to load.

Version-Release number of selected component (if applicable):
kernel-2.6.23.9-85.fc8

How reproducible:
Always.

Results:
dmesg says:
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 16 (level, low) -> IRQ 16
cannot find the slot for index 0 (range 0-0), error: -16
hda-intel: Error creating card!
HDA Intel: probe of 0000:00:1b.0 failed with error -12

Relevant device numbers are:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)

03:00.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Comment 1 Pawel Salek 2008-01-06 06:06:17 EST
Created attachment 290905 [details]
Full dmesg
Comment 2 Pawel Salek 2008-01-06 06:08:35 EST
Created attachment 290906 [details]
output of /sbin/lspci
Comment 3 Chuck Ebbert 2008-01-08 13:59:22 EST
Try editing /etc/modprobe.conf and changing the slot number to 1 for the intel
adapter. The new card took slot zero.
Comment 4 Pawel Salek 2008-01-12 17:29:46 EST
Affirmative: changing index=0 option associated with the snd-hda-intel module to
index=1 fixes the problem. It is a pity that whatever added modprobe.conf for
snd-cmpci did not update the option for hda-intel as well... The conclusion is
that snd-hda-intel module is just fine, maybe user friendliness of the
modprobe.conf could be improved (not sure whether it qualifies as a bug per se).
Comment 5 Chuck Ebbert 2008-01-16 15:02:22 EST
Kernel 2.6.25 will make it easier to permanently reserve slots.

Closing as NOTABUG since there is no kernel bug here and it's unclear what to
file a bug against for the configuration issue.

Note You need to log in before you can comment on or make changes to this bug.