Bug 427690 - Cannot start qemu guest with SDL window
Cannot start qemu guest with SDL window
Status: CLOSED DUPLICATE of bug 240233
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 13:36 EST by Alexey Torkhov
Modified: 2008-04-03 21:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 21:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2008-01-06 13:36:56 EST
Description of problem:
Cannot start qemu guest with SDL window.

Version-Release number of selected component (if applicable):
virt-manager-0.5.2-2.fc8
qemu-0.9.0-5.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Create qemu virtual machine.
2. Change display device to "Local SDL window".
3. Start.

Actual results:
Error:
Unable to start virtual machine '<class 'libvirt.libvirtError'>
virDomainCreate() failed QEMU quit during console startup
Could not initialize SDL - exiting

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/console.py", line 520, in control_vm_run
    self.vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 377, in startup
    self.vm.create()
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 228, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed QEMU quit during console startup
Could not initialize SDL - exiting

'

Expected results:
SDL window appear.

Additional info:
Comment 1 Daniel Berrange 2008-04-03 21:05:48 EDT

*** This bug has been marked as a duplicate of 240233 ***

Note You need to log in before you can comment on or make changes to this bug.