Bug 427693 - Thinkpad X61s battery not detected
Summary: Thinkpad X61s battery not detected
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-06 19:37 UTC by Simon Karpen
Modified: 2008-03-07 15:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.25-0.93.rc4.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 01:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Karpen 2008-01-06 19:37:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3pre) Gecko/2008010314 Fedora/1.9-0.beta2.6.fc9 Minefield/3.0b3pre

Description of problem:
/proc/acpi/battery and its subdirectories and such do not exist. gnome-power-manager is unable to determine the battery runtime remaining, and is unable to show an accurate battery percentage when on battery. 

Version-Release number of selected component (if applicable):
kernel-2.6.24-0.133.rc6.git8.fc9

How reproducible:
Always


Steps to Reproduce:
1. ls /proc/acpi
2. notice lack of batter
3. use gnome-power-manager applet and notice lack of discharge or accurate runtime

Actual Results:
/proc/acpi/battery does not exist, gnome-power-manager cannot show runtime or battery charge

Expected Results:
/proc/acpi/battery/BAT0/... with battery information, including charge state. gnome-power-manager showing useful information.

Additional info:
This is a regression relative to Fedora 8; kernel kernel-2.6.23.9-85.fc8 found the battery without a problem.

Comment 1 Simon Karpen 2008-01-06 19:42:58 UTC
There is some sort of communication happening, because the power remaining just
went from 96% to 79% with no intermediate steps. (after running on battery for
maybe an hour). Still not sure exactly what's going on.

Comment 2 Simon Karpen 2008-01-06 19:56:45 UTC
As yet another followup, it's back to saying 96% on a laptop that's been running
off battery for 90 minutes. (the X61s is efficient, but it's not *that* good). 

Comment 3 denis ivanov 2008-01-15 14:11:00 UTC
The same problem with current rawhide:

kernel-2.6.24-0.150.rc7.git4.fc9

$ ls -l /proc/acpi/*bat*
ls: cannot access /proc/acpi/*bat*: No such file or directory

Maybe problem in kernel config (CONFIG_ACPI_PROCFS_POWER)?

$ cat config-2.6.24-0.150.rc7.git4.fc9 |grep ACPI|grep PROCFS
CONFIG_ACPI_PROCFS=y
# CONFIG_ACPI_PROCFS_POWER is not set


Comment 4 Simon Karpen 2008-01-17 11:55:38 UTC
With kernel-2.6.24-0.155.rc7.git6.fc9 I can now see the battery in /proc/acpi,
though gnome-power-manager shows two batteries (minor issue compared to no
charge monitoring)

/proc/acpi/battery/BAT0 only shows one battery

Comment 5 denis ivanov 2008-01-17 23:18:09 UTC
Yeah, the same problem. I have 2 batteries, but battery monitor shows 4...
Seems some procfs-ACPI vs. HAL problem.

But also seems this bug is unread by kernel maintainers? ;)

$ lshal |grep battery.charge_level.last_full
  battery.charge_level.last_full = 89640  (0x15e28)  (int)
  battery.charge_level.last_full = 37910  (0x9416)  (int)
  battery.charge_level.last_full = 37910  (0x9416)  (int)   # THIS IS DUPE
  battery.charge_level.last_full = 89640  (0x15e28)  (int)  # THIS IS DUPE


Comment 6 denis ivanov 2008-01-17 23:21:07 UTC
With kernel kernel-2.6.24-0.150.rc7.git4.fc9, /proc/acpi/battery/* was absent
but lshal listed 2 batteries (it was right for my computer)


Comment 7 denis ivanov 2008-01-24 09:44:48 UTC
kernel-2.6.24-0.157.rc8.fc9

same problem

Comment 8 denis ivanov 2008-01-30 22:37:56 UTC
kernel-2.6.24-9.fc9.i686

still the same problem
four batteries found instead of real two


Comment 9 Simon Karpen 2008-03-06 14:52:30 UTC
2.6.24.1-31.fc9 plus current rawhide finds exactly one battery correctly. 

Denis, are you seeing this too? (I'd like a second before marking this as resolved)

Comment 10 denis ivanov 2008-03-06 22:50:23 UTC
Batteries is ok with kernel-2.6.25-0.93.rc4.fc9.i686

Seems fixed. Please close the bug.


Comment 11 denis ivanov 2008-03-07 15:11:48 UTC
Seems the problem wasn't in kernel.
Now I back to older 2.6.24 kernel and all is ok.
Maybe somethings in HAL was fixed.


Note You need to log in before you can comment on or make changes to this bug.