Bug 427696 - kmod-em8300 doesn't seem to be built automatically for new kernels
kmod-em8300 doesn't seem to be built automatically for new kernels
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: em8300 (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 15:56 EST by Jón Fairbairn
Modified: 2008-01-06 16:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 16:57:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2008-01-06 15:56:06 EST
Description of problem:
yum offers a kernel update, but kmod-em8300 isn't available for that kernel

Version-Release number of selected component (if applicable):
em8300-0.16.3-1.fc7
kmod-em8300-0.16.3-4.2.6.23.8_34.fc7
kernel-2.6.23.8-34.fc7

but yum offers

kernel.x86_64                            2.6.23.12-52.fc7       updates         
kernel-devel.x86_64                      2.6.23.12-52.fc7       updates         
kernel-doc.noarch                        2.6.23.12-52.fc7       updates         
kernel-headers.x86_64                    2.6.23.12-52.fc7       updates         


How reproducible:
fairly often, but this one has been lagging for quite a few days

Steps to Reproduce:
1. install kmod-em8300
2. wait
3. yum check-update
  
Actual results:
kmod-em8300 doesn't appear straight away.

Expected results:

kmod-em8300 matching the kernel should automatically be
built and appear in the repo as soon as a new kernel
appears.

Additional info:
Comment 1 Ville Skyttä 2008-01-06 16:57:15 EST
That's right, such an infrastructure does not exist.

It is also pretty much certain that it will not be implemented in Fedora either
because external kernel module packages are banned from F-9 onwards:
http://fedoraproject.org/wiki/DavidWoodhouse/KmodProposal (accepted by FESCO)

I hope that the em8300 modules will be submitted for inclusion in vanilla
kernel.org kernels before too long - that way they'd soon be a part of the
actual kernel packages too, making this issue moot.  It is possible that they
will be included as a patch in the Fedora kernel packages slightly before that,
but cannot promise anything as it's not really my call.

For F-9+, if the em8300 modules aren't yet included in Fedora kernel packages,
they'll be available from Livna/RPMFusion, but it's likely that that way the
issue at hand would continue to exist.
Comment 2 Ville Skyttä 2008-01-06 16:59:04 EST
By the way, kmod-em8300 for the latest F-7 update kernel has been already built
last Thursday, it's just waiting for the repository managers to sign and push
them as updates.  Meanwhile, you can grab them at
http://koji.fedoraproject.org/koji/buildinfo?buildID=29895

Note You need to log in before you can comment on or make changes to this bug.