Bug 4277 - rpm -V provides differing results as user and root.
Summary: rpm -V provides differing results as user and root.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-30 17:53 UTC by craig
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-30 18:00:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description craig 1999-07-30 17:53:54 UTC
When I run rpm 2.5.5, I get differing results:

[root@contraption craig]# rpm -vv -V zgv
D: opening database in //var/lib/rpm/
D: verifying record number 2108824
D: dependencies: looking for ld-linux.so.2
D: dependencies: looking for libc.so.6
D: dependencies: looking for libjpeg.so.62
D: dependencies: looking for libm.so.6
D: dependencies: looking for libpng.so.2
D: dependencies: looking for libvga.so.1
D: dependencies: looking for libvgagl.so.1
D: dependencies: looking for libz.so.1

and:

[craig@contraption ~]$ rpm -vv -V zgv
D: opening database in //var/lib/rpm/
D: verifying record number 2108824
D: dependencies: looking for ld-linux.so.2
D: dependencies: looking for libc.so.6
D: dependencies: looking for libjpeg.so.62
D: dependencies: looking for libm.so.6
D: dependencies: looking for libpng.so.2
D: dependencies: looking for libvga.so.1
D: dependencies: looking for libvgagl.so.1
D: dependencies: looking for libz.so.1
..5.....   /usr/bin/zgv

This happens with several packages, namely zgv-3.0-6 and
util-linux-2.8-11.

Comment 1 Jeff Johnson 1999-07-30 18:00:59 UTC
Rpm-2.5.5 displays unreadable (e.g. because of permissions) files
as md5 failures. Since root can read the file, rpm can calculate
the md5 sum.

Rpm-3.0.x displays a ? rather than the misleading 5 in this
circumstance.


Note You need to log in before you can comment on or make changes to this bug.