Bug 427705 - problem with nvidia driver 169.07
problem with nvidia driver 169.07
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 18:15 EST by Yu Sheng
Modified: 2008-01-07 19:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 19:30:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yu Sheng 2008-01-06 18:15:50 EST
After yum updates my graphics driver from from 
kmod-nvidia - 100.14.19-1.2.6.23.8_34.fc7.i686
to
kmod-nvidia - 169.07-1.2.6.23.12_52.fc7.i686

My code for a project does not compile any more. Here are the errors given by gcc:
/usr/lib/nvidia/libGLcore.so.1: undefined reference to `_nv000042gl'
/usr/lib/libGL.so: undefined reference to `_nv000044gl'

Here are some basic information about my computer:
uname -a
Linux node-info 2.6.23.12-52.fc7 #1 SMP Tue Dec 18 21:18:02 EST 2007 i686 i686
i386 GNU/Linux
CPU: Intel core 2 Duo E6400
Graphics card: nvidia 7600GS, I'm using a livna graphics driver.
The X windows runs fine, compiz fusion also works.

I found similar report on
http://www.gossamer-threads.com/lists/atrpms/users/10244
, the problem comes to be a bug in yum (Bugzilla Bug 425937). I don't know
whether it is the same problem since my X server works fine and I don't think
yum picked up a wrong arch.
Comment 1 Matěj Cepl 2008-01-07 19:30:19 EST
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.