Bug 427734 - "skip local delivery(3): <> -> <spam-quarantine>" etc. is mis-handled
"skip local delivery(3): <> -> <spam-quarantine>" etc. is mis-handled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 04:24 EST by Robert Scheck
Modified: 2008-01-21 07:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 07:01:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Non-catched amavisd log messages (612 bytes, text/plain)
2008-01-19 19:17 EST, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2008-01-07 04:24:01 EST
Description of problem:
Using amavisd-new with Postfix and its SMTP-proxy, I've many many log lines 
like in /var/log/maillog:

Jan  7 04:05:20 smith amavis[13547]: (13547-11) skip local delivery(3): <> -> 
<spam-quarantine>
Jan  7 06:59:52 smith amavis[13329]: (13329-15) skip local delivery(3): <> -> 
<bad-header-quarantine>

Unfortunately, logwatch currently doesn't catch them, so my logwatch mail looks 
like this:

 **Unmatched Entries**
        2   config files read: /etc/amavisd/amavisd.conf
        1   (31387-12) skip local delivery(3): <> -> <spam-quarantine>
        1   (31386-12) skip local delivery(3): <> -> <spam-quarantine>
        1   (11596-20) skip local delivery(3): <> -> <spam-quarantine>
        1   (31481-09) skip local delivery(3): <> -> <spam-quarantine>
        1   (10313-01) skip local delivery(3): <> -> <spam-quarantine>
[...]
        1   (11588-12) skip local delivery(3): <> -> <spam-quarantine>
        1   (11594-11) skip local delivery(3): <> -> <spam-quarantine>
        1   (31490-13) skip local delivery(3): <> -> <bad-header-quarantine>
        1   (31372-15) skip local delivery(3): <> -> <spam-quarantine>
        1   (11593-06) skip local delivery(3): <> -> <spam-quarantine>
        1   (11589-19) skip local delivery(3): <> -> <spam-quarantine>
[... and so on]


Version-Release number of selected component (if applicable):
logwatch-7.3.6-13

How reproducible:
Everytime when using Amavisd-New with SMTP-Proxy from Postfix

Actual results:
"skip local delivery(3): <> -> <spam-quarantine>" etc. is mis-handled

Expected results:
Either ignoring these log lines or handling them correct (counting or what 
else).
Comment 1 Ivana Varekova 2008-01-08 08:26:44 EST
Thanks. Fixed in logwatch-7.3.6-16.fc9.
Comment 2 Robert Scheck 2008-01-19 19:17:45 EST
Created attachment 292282 [details]
Non-catched amavisd log messages

Re-opening, because the attached log messages from amavisd are not catched up 
by logwatch.
Comment 3 Robert Scheck 2008-01-19 19:20:47 EST
Sorry, we're missing some further messages thus I'm reopening. I don't want to 
waste another ID for that ;-)
Comment 4 Ivana Varekova 2008-01-21 07:01:09 EST
Thanks. Fixed in logwatch-7.3.6-17.fc9.

Note You need to log in before you can comment on or make changes to this bug.