Bug 427802 - Freshly plugged HP printers do not print until reboot
Freshly plugged HP printers do not print until reboot
Status: CLOSED DUPLICATE of bug 424331
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 12:02 EST by Thomas Canniot
Modified: 2008-01-07 12:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 12:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2008-01-07 12:02:32 EST
Description of problem:
My two HP printers do not print when they are just plugged.
HP Deskjet 3320
HP Photosmart D5160

Version-Release number of selected component (if applicable):
cups-1.3.4-4.fc8
libgnomecups-0.2.2-11.fc8
cups-libs-1.3.4-4.fc8
hal-cups-utils-0.6.13-2.fc8
hpijs-2.7.7-6.fc8
hplip-2.7.7-6.fc8


Steps to Reproduce:
1. Boot Fedora 8
2. Plug the printer when it's booted up
3. Launch a print task
4. The printer does not print
5. Reboot and it will print your document




Here is the /var/log/messages output :

Jan  7 17:53:23 annifrid kernel: usb 1-8: new high speed USB device using
ehci_hcd and address 7
Jan  7 17:53:23 annifrid kernel: usb 1-8: configuration #1 chosen from 1 choice
Jan  7 17:53:23 annifrid kernel: usblp0: USB Bidirectional printer dev 7 if 0
alt 0 proto 2 vid 0x03F0 pid 0xC402
Jan  7 17:53:23 annifrid kernel: scsi4 : SCSI emulation for USB Mass Storage devices
Jan  7 17:53:27 annifrid python: hp-probe[5711]: warning: No devices found on
the 'usb' bus. If this isn't the result you are expecting,
Jan  7 17:53:27 annifrid python: hp-probe[5711]: warning: check to make sure
your devices are properly connected and powered on.
Jan  7 17:53:28 annifrid python: hp-probe[5713]: warning: No devices found on
the 'usb' bus. If this isn't the result you are expecting,
Jan  7 17:53:28 annifrid python: hp-probe[5713]: warning: check to make sure
your devices are properly connected and powered on.
Jan  7 17:53:28 annifrid kernel: scsi 4:0:0:0: Direct-Access     HP      
Photosmart D5100 1.00 PQ: 0 ANSI: 2
Jan  7 17:53:28 annifrid kernel: sd 4:0:0:0: [sdb] Attached SCSI removable disk
Jan  7 17:53:28 annifrid kernel: sd 4:0:0:0: Attached scsi generic sg2 type 0
Jan  7 17:55:22 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Jan  7 17:55:22 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 1003: unable to open
hp:/usb/Photosmart_D5100_series?serial=MY6CJ3127504SK
Jan  7 17:55:22 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK: INFO:
open device failed; will retry in 30 seconds...
Jan  7 17:55:27 annifrid hpijs: io/hpmud/musb.c 549: invalid product id string:
Operation not permitted
Jan  7 17:55:27 annifrid hpijs: io/hpmud/musb.c 1003: unable to open
hp:/usb/Photosmart_D5100_series?serial=MY6CJ3127504SK
Jan  7 17:55:53 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Jan  7 17:55:53 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 1003: unable to open
hp:/usb/Photosmart_D5100_series?serial=MY6CJ3127504SK
Jan  7 17:55:53 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK: INFO:
open device failed; will retry in 30 seconds...
Jan  7 17:56:23 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Jan  7 17:56:23 annifrid Photosmart_D5100_series?serial=MY6CJ3127504SK:
io/hpmud/musb.c 1003: unable to open
hp:/usb/Photosmart_D5100_series?serial=MY6CJ3127504SK

And so on :(

Tested on 3 different PCs.
Comment 1 Tim Waugh 2008-01-07 12:07:14 EST
This is a udev problem.

*** This bug has been marked as a duplicate of 424331 ***

Note You need to log in before you can comment on or make changes to this bug.