Bug 427804 - HP Compaq NX6125 wifi led lights off during F8 boot
HP Compaq NX6125 wifi led lights off during F8 boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 12:09 EST by Thomas Canniot
Modified: 2013-01-09 23:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 15:11:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2008-01-07 12:09:33 EST
Description of problem:
On Fedora 7, during the boot process, the blue wifi LED on this laptop turned on
when NetworkManager was started.
On Fedora 8, the process is reversed : the light is turned on during the boot
process and once NetworkManager is launched the LED is turned OFF. It should be
the contrary : no light during the boot process and turned on when NM get started.


Please help me to help you debugging this, as I really don't know which
component is affected. Thanks.
Comment 1 Bill Nottingham 2008-01-07 15:06:05 EST
Initial guess would be kernel (driver), followed by NM, and then HAL.

If you do 'ip link set dev <whatever the device is> down', does the light change?
Comment 2 Thomas Canniot 2008-01-07 16:23:31 EST
Unfortunately no it does not do anything concerning the light... It cuts off the
connection, but nm-applet does not notice either.
Comment 3 Bill Nottingham 2008-01-07 16:28:59 EST
Does using the F7 kernel in F8 yield any different behavior?
Comment 4 Thomas Canniot 2008-01-07 17:15:03 EST
Yes, but not for the wifi led. I could decide to give life or not to the
(un)mute led with the f7 kernel on f8 when I pushed the mute switch. But nothing
for the wifi even before NM get loaded.
Comment 5 Bill Nottingham 2008-01-07 17:24:24 EST
Assigning to hal-info - looks like there's a quirk wrong somewhere?
Comment 6 David Zeuthen 2008-01-07 17:55:51 EST
I doubt it. I think it's actually the kernel driver but I think dcbw knows
better than me. So -> NM.
Comment 7 Thomas Canniot 2008-01-08 13:11:52 EST
In fact as I noticed it in #4, the led of the (un)mute button is also no more
functional, and it worked as well on f7.

I don't know if managing both led is link to the same device or not however.
Comment 8 Thomas Canniot 2008-01-29 14:33:01 EST
The wifi LED came back with the 2.6.23.14-107.fc8 kernel, but not the mute LED :)
Comment 9 Dan Williams 2008-01-29 14:43:10 EST
yeah, kernel bug...  might ACPI related or require some kernel module to be
loaded to handle special keys and LED behavior like asus_acpi or tpbuttons.
Comment 10 Thomas Canniot 2008-02-03 15:11:48 EST
ok everything is back to order now.

I love these bugs that solve themselves by magic :)

Note You need to log in before you can comment on or make changes to this bug.