Bug 427831 - Pulseaudio daemon doesn't run after fresh F8 installation - Realtek ALC882
Pulseaudio daemon doesn't run after fresh F8 installation - Realtek ALC882
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 13:38 EST by Volnei
Modified: 2009-01-07 13:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-22 10:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tar ball - scsrun.log + scsconfig.log (50.00 KB, application/x-tar)
2008-01-07 13:38 EST, Volnei
no flags Details
New files scsconfig.log and scsrun.log (11.70 KB, application/zip)
2008-02-13 05:37 EST, Volnei
no flags Details
results of pulseaudio -vvv command (7.81 KB, text/plain)
2008-02-29 05:47 EST, Volnei
no flags Details
dmesg (23.64 KB, text/plain)
2008-03-17 12:58 EDT, Volnei
no flags Details
scsconfig (42.76 KB, application/octet-stream)
2008-03-17 13:00 EDT, Volnei
no flags Details
scsrun (3.20 KB, application/octet-stream)
2008-03-17 13:00 EDT, Volnei
no flags Details

  None (edit)
Description Volnei 2008-01-07 13:38:14 EST
Description of problem:
Upgrade (complete reinstallation) from FC7 to 8 and the sound stop to work.
My sound device every works fine since Fedora 5 to 7.


Attached a mix of scsrun.log and scsconfig.log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Volnei 2008-01-07 13:38:14 EST
Created attachment 290994 [details]
Tar ball - scsrun.log + scsconfig.log
Comment 2 Volnei 2008-02-13 05:37:32 EST
Created attachment 294764 [details]
New files scsconfig.log and scsrun.log
Comment 3 Volnei 2008-02-13 05:39:02 EST
updating of the information about this problem

kernel-2.6.23.15-137.fc8
alsa-lib-devel-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.15-2.fc8
alsa-lib-1.0.15-1.fc8
bluez-utils-alsa-3.20-4.fc8
alsa-utils-1.0.15-1.fc8
Comment 4 Martin Stransky 2008-02-20 02:49:38 EST
Your sound card is detected properly. 

See this:

*** PULSEAUDIO: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused

Check your pulseaudio configuration and you have to enable hal and consolekit
system services.
Comment 5 Volnei 2008-02-20 05:35:19 EST
Hi,

When I run pulseaudio this message is showed: Connection failed: Connection 
refused
The hal and consolekit is was loaded on system's boot.
8        2116  0.0  0.3   5876  3672 ?        Ss   07:17   0:00 hald
root      2117  0.0  0.0   3296   936 ?        S    07:17   0:00 hald-runner
root      2131  0.0  0.0   3396   996 ?        S    07:17   0:00
hald-addon-input: Listening on /dev/input/event4 /dev/input/event3 /dev/input/event1
root      2158  0.0  0.0   3404   988 ?        S    07:17   0:00
/usr/libexec/hald-addon-cpufreq
68        2159  0.0  0.0   2156   828 ?        S    07:17   0:00
hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root      2172  0.0  0.0   3396   888 ?        S    07:17   0:00
hald-addon-storage: polling /dev/sr0 (every 2 sec)
root      2175  0.0  0.0   3396   888 ?        S    07:17   0:00
hald-addon-storage: polling /dev/sr1 (every 2 sec)
root      2846  0.0  0.0   4072   740 pts/2    S+   07:34   0:00 grep hal
[root@barney ~]# ps aux | grep console
root      2009  0.0  0.2   7792  2148 ?        Ssl  07:17   0:00 console-kit-daemon


But the kernel don't recognize this Realtek 882
hda_codec: Unknown model for ALC882, trying auto-probe from BIOS...

kernel-2.6.23.15-137.fc8

Thanks
Comment 6 Martin Stransky 2008-02-20 05:42:49 EST
I see. So it looks like a kernel/driver problem. You may report it to ALSA
project (www.alsa-project.org) and ask for help there. 
Comment 7 Martin Stransky 2008-02-22 06:02:06 EST
Err, your sound device seems to be detected properly. Moved to pulseaudio.
Comment 8 Volnei 2008-02-22 06:25:31 EST
I already report to ALSA too. Maybe the if yours update ALSA to 1.0.16 help to
resolve the problem.

My ticket im ALSA Project is: 3707
Comment 9 Volnei 2008-02-22 06:25:50 EST
Sorry: 3704
Comment 10 Lubomir Kundrak 2008-02-28 12:55:35 EST
Please run "pulseaudio -vvv" and paste the results.
Comment 11 Volnei 2008-02-29 05:47:45 EST
Created attachment 296324 [details]
results of pulseaudio -vvv command
Comment 12 Volnei 2008-02-29 05:48:27 EST
The results of pulseaudio -vvv command are attached.
Comment 13 Volnei 2008-02-29 06:00:11 EST
Translations of any terms from Pt_BR to En_US

Pt_BR                    En_US

Argumento Inválido       Invalid argument
Operação não permitida   Operation denied
Comment 14 Lubomir Kundrak 2008-02-29 06:24:39 EST
D: alsa-util.c: Trying hw:0 as last resort...
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: Dispositivo inexistente

seems like you don't have permissions for the audio device.
Could you please run "getfacl /dev/snd/controlC0" and paste the results?
Comment 15 Volnei 2008-02-29 06:31:13 EST
getfacl /dev/snd/controlC0

getfacl: Removing leading '/' from absolute path names
# file: dev/snd/controlC0
# owner: root
# group: root
user::rw-
user:gdm:rw-
group::rw-
mask::rw-
other::---
Comment 16 Volnei 2008-03-17 12:58:06 EDT
Created attachment 298283 [details]
dmesg
Comment 17 Volnei 2008-03-17 12:59:41 EDT
New kernels update but the problem persist.

From: kernel-2.6.24.3-12.fc8
to: kernel-2.6.24.3-34.fc8

attached files: scsconfig.log; scsrun.log; dmesg.txt 
Comment 18 Volnei 2008-03-17 13:00:13 EDT
Created attachment 298284 [details]
scsconfig
Comment 19 Volnei 2008-03-17 13:00:38 EDT
Created attachment 298285 [details]
scsrun
Comment 20 Lubomir Kundrak 2008-03-17 13:26:05 EDT
Sorry for not responding.

I have(In reply to comment #15)
> getfacl /dev/snd/controlC0
> 
> getfacl: Removing leading '/' from absolute path names
> # file: dev/snd/controlC0
> # owner: root
> # group: root
> user::rw-
> user:gdm:rw-
> group::rw-
> mask::rw-
> other::---

This means that you simply don't have the right ACLs.
So a couple of more quiestions:

1.) Do you run Gnome or KDE?

2.) What version of hal do you have?
# rpm -q hal

3.) What consolekit do you have?
# rpm -q ConsoleKit

4.) Did you suspend and resume your machine, did you switch wirtual terminals?

5.) Do you have a serial console?

6.) Please paste the output of following:
# cl-list-sessions

Thanks!
Comment 21 Volnei 2008-03-18 14:06:22 EDT
1.) Do you run Gnome or KDE?
KDE 3.5.9-5.fc8

2.) What version of hal do you have?
# rpm -q hal
hal-0.5.10-1.fc8.2

3.) What consolekit do you have?
# rpm -q ConsoleKit
ConsoleKit-0.2.3-3.fc8.1

4.) Did you suspend and resume your machine, did you switch wirtual terminals?
No.

5.) Do you have a serial console?
No.

6.) Please paste the output of following:
# cl-list-sessions
Sorry. I don't know whait is it.
Tell me what I've to do.

Thanks
Comment 22 Volnei 2008-03-18 14:16:28 EDT
This error occurs for don't have permissions?

ALSA sound/pci/hda/hda_intel.c:732: codec_mask = 0x4
hda_codec: Unknown model for ALC882, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:2757: autoconfig: line_outs=4
(0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:2761:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2765:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2773:    inputs: mic=0x18, fmic=0x19, line=0x1a,
fline=0x0, cd=0x1c, aux=0x0
Comment 23 Lubomir Kundrak 2008-03-18 14:48:18 EDT
(In reply to comment #21)
> 1.) Do you run Gnome or KDE?
> KDE 3.5.9-5.fc8

Do you have kde-settings-pulseaudio installed?

> 6.) Please paste the output of following:
> # cl-list-sessions
> Sorry. I don't know whait is it.
> Tell me what I've to do.

Sorry, I made a typo.  I meant "ck-list-sessions".

(In reply to comment #22)
> This error occurs for don't have permissions?
> 
> ALSA sound/pci/hda/hda_intel.c:732: codec_mask = 0x4
> hda_codec: Unknown model for ALC882, trying auto-probe from BIOS...
> ALSA sound/pci/hda/hda_codec.c:2757: autoconfig: line_outs=4
> (0x14/0x15/0x16/0x17/0x0)
> ALSA sound/pci/hda/hda_codec.c:2761:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
> ALSA sound/pci/hda/hda_codec.c:2765:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
> ALSA sound/pci/hda/hda_codec.c:2773:    inputs: mic=0x18, fmic=0x19, line=0x1a,
> fline=0x0, cd=0x1c, aux=0x0

It's not an error, merely an information message.
Comment 24 Lubomir Kundrak 2008-03-18 14:48:55 EDT
Also, did you use gdm or kdm to log in?
Comment 25 Volnei 2008-03-18 15:24:59 EDT
Session1:
        uid = '0'
        realname = 'root'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2008-03-18T10:29:08Z'

I use kdm

No aboute pulseaudio I've installed:

pulseaudio-module-x11-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
akode-pulseaudio-2.0.2-4.fc8
pulseaudio-core-libs-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-2.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8

Is necessary install kde-settings-pulseaudio?
Comment 26 Volnei 2008-03-18 15:52:43 EDT
Sorry!!! I use GDM no kdm.
Comment 27 Volnei 2008-03-22 09:01:00 EDT
Sound's ALIVE!!!

After this update this sound come back to works.

Mar 22 09:30:19 Updated: krb5-libs - 1.6.2-14.fc8.i386
Mar 22 09:30:19 Updated: audit-libs - 1.6.8-3.fc8.i386
Mar 22 09:30:20 Updated: kde-settings - 3.5-38.fc8.noarch
Mar 22 09:30:20 Updated: kde-settings-pulseaudio - 3.5-38.fc8.noarch
Mar 22 09:30:21 Updated: kde-settings-kdm - 3.5-38.fc8.noarch
Mar 22 09:30:31 Updated: samba-common - 3.0.28a-0.fc8.i386
Mar 22 09:30:33 Updated: xine-lib - 1.1.11-1.fc8.i386
Mar 22 09:30:35 Updated: xorg-x11-server-Xorg - 1.3.0.0-44.fc8.i386
Mar 22 09:30:35 Updated: libnl - 1.1-1.fc8.i386
Mar 22 09:30:35 Updated: ustr - 1.0.4-6.fc8.i386
Mar 22 09:30:36 Updated: nss_db - 2.2-40.fc8.i386
Mar 22 09:30:36 Updated: xorg-x11-drv-amd - 2.7.7.7-2.fc8.i386
Mar 22 09:30:39 Updated: doxygen - 1:1.5.5-2.fc8.i386
Mar 22 09:30:40 Updated: libsmbclient - 3.0.28a-0.fc8.i386
Mar 22 09:30:40 Updated: eject - 2.1.5-7.fc8.i386
Mar 22 09:30:41 Updated: audit-libs-python - 1.6.8-3.fc8.i386
Mar 22 09:30:42 Updated: samba - 3.0.28a-0.fc8.i386
Mar 22 09:30:43 Updated: xine-lib-arts - 1.1.11-1.fc8.i386
Mar 22 09:30:44 Updated: audit - 1.6.8-3.fc8.i386
Mar 22 09:30:44 Updated: krb5-workstation - 1.6.2-14.fc8.i386
Mar 22 09:30:46 Updated: samba-client - 3.0.28a-0.fc8.i386
Mar 22 09:30:47 Updated: krb5-devel - 1.6.2-14.fc8.i386

VERY VERY THANKS.

if you need any additional information, is just ask.
Comment 28 Lubomir Kundrak 2008-03-22 10:51:29 EDT
I suspect it was kde-settings-pulseaudio.
Closing.

Note You need to log in before you can comment on or make changes to this bug.