Bug 427846 - pup consumes huge amounts of memory, machine crawls.
pup consumes huge amounts of memory, machine crawls.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 15:18 EST by Harm Verhagen
Modified: 2015-07-12 21:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harm Verhagen 2008-01-07 15:18:09 EST
Description of problem:
Whenever pup is running, and when it is actively updating my system it consumes
huge mounts of memory making my machine very unresponsive.

on my 1GByte machine it consumes upto 30% of the memory.


Version-Release number of selected component (if applicable):
Linux home.verhagen.tv 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007 x86_64
x86_64 x86_64 GNU/Linux
[
harm@home ~]$ rpm -q pirut
pirut-1.3.28-1.fc8





How reproducible:



Steps to Reproduce:
1.  pup notifies user in panel that 26 updates are availabe (so not even a
_high_ number of updates)
2. user gives root passwd to the updates
3.  updater starts downloading & installing
  
Actual results:
machine is unresponsve during the update procedure.
The memory usage is enormous.

top>
Cpu(s):  3.5%us,  1.3%sy,  0.0%ni, 42.0%id, 53.2%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    961892k total,   952704k used,     9188k free,     3752k buffers
Swap:  1020088k total,   824104k used,   195984k free,    67224k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
27379 root      20   0  677m 272m  14m S    0 29.0   0:38.50 pup             






Expected results:
a package updater consumes a _low_ amount of memory.. and my machine keeps
responsive.

Additional info:

Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
1GB ram, 1BG swap.
used as desktop machine.
Comment 1 Jeremy Katz 2008-05-28 15:28:52 EDT
This is just due to how objects work on x86_64 in python.  There's really not
any way to change it.
Comment 2 Richard Jasmin 2015-07-12 21:16:14 EDT
Then maybe theres a memory leak in python that needs to be addressed? Needs more investigation if you ask me.

Note You need to log in before you can comment on or make changes to this bug.