Bug 427889 - XMLRPC function nameToId
XMLRPC function nameToId
Status: CLOSED DUPLICATE of bug 427893
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks: RHBZ30UpgradeTracker 406131 427053
  Show dependency treegraph
 
Reported: 2008-01-07 20:59 EST by Noura El hawary
Modified: 2013-06-24 00:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 20:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to Bugzilla/WebService/User.pm (1.40 KB, text/plain)
2008-01-15 01:57 EST, Noura El hawary
no flags Details
patch for WebService module that includes function login_to_id (1.76 KB, text/plain)
2008-01-16 23:50 EST, Noura El hawary
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 412725 None None None Never

  None (edit)
Description Noura El hawary 2008-01-07 20:59:40 EST
write xmlrpc function nameToId that is to be contributed to the upstream
. Please refer to the following url for details on Bugzilla::RPC 2.18 functions mapped to upstream Bugzilla::WebService and for 2.18 xmlrpc functions sorted by percentage of calls: https://engineering.redhat.com/trac/bugzilla-3.0-rh/wiki/XmlrpcCrossComparison#a2.18xmlrpcfunctionssortedbypercentageofcalls
Comment 1 Noura El hawary 2008-01-15 01:57:47 EST
Created attachment 291689 [details]
patch to Bugzilla/WebService/User.pm

the patch contains 2 functions one to get login name from userid and one to get
userid from login name, basically those 2 functions are similar to our xmlrpc
functions in rh_bugzilla_2_18  nameToId and IdToName
Comment 2 Noura El hawary 2008-01-15 02:11:21 EST
we can discuss with the upstream if it is best to pass one login name of list of
login names.
Comment 3 Noura El hawary 2008-01-16 23:50:25 EST
Created attachment 291952 [details]
patch for WebService module that includes function login_to_id

I created a bug for that in the upstream :

https://bugzilla.mozilla.org/show_bug.cgi?id=412725

Attached is another version for the previous patch I changed it to accept a
list of login names instead of a single login name. "please note that the patch
also includes function for converting id to name"
Comment 4 Noura El hawary 2008-01-17 23:51:33 EST
please see:

https://bugzilla.redhat.com/show_bug.cgi?id=427893#c4
Comment 5 Noura El hawary 2008-01-21 20:05:34 EST
This function and IdToName function will both be replaced by User.get() 

closing this bug as its work is just will be duplicate for function IdToName

*** This bug has been marked as a duplicate of 427893 ***

Note You need to log in before you can comment on or make changes to this bug.