Bug 427949 - switchspell plugin reads list of dictionaries from aspell when pidgin/gtkspell is actually using enchant
switchspell plugin reads list of dictionaries from aspell when pidgin/gtkspel...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: purple-plugin_pack (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Release...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 23:22 EST by Kevin Kofler
Modified: 2008-01-08 21:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 21:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2008-01-07 23:22:28 EST
Description of problem:
The switchspell plugin in purple-plugin_pack reads its list of dictionaries 
from aspell. This is broken, because gtkspell in Rawhide is using enchant, not 
aspell.

While this specfile change:
http://cvs.fedora.redhat.com/viewcvs/rpms/purple-plugin_pack/devel/purple-plugin_pack.spec?r1=1.2&r2=1.3
(which adds a BR aspell-devel) gets the plugin to build, it is still doing the 
wrong thing. Instead, the plugin needs to be patched to obtain its list of 
dictionaries from enchant instead.

Michael Schwendt fixed a similar issue in sylpheed with this patch:
http://cvs.fedora.redhat.com/viewcvs/rpms/sylpheed/devel/sylpheed-2.4.8-enchant.patch?rev=1.2&view=markup

Version-Release number of selected component (if applicable):
purple-plugin_pack-2.2.0-3.fc9 

Additional info:
See also http://fedoraproject.org/wiki/FeatureDictionary
Comment 1 Kevin Kofler 2008-01-07 23:23:51 EST
Oops, correct URL:
http://fedoraproject.org/wiki/Releases/FeatureDictionary
Comment 2 Ignacio Vazquez-Abrams 2008-01-08 02:50:42 EST
Here's a first-try patch. I've asked the Abiword people if it looks sane (since
I know next-to-nothing about enchant) but no response yet.

http://ivazquez.fedorapeople.org/files/purple-plugin_pack-2.2.0-switchspell-enchant.patch
Comment 3 Ignacio Vazquez-Abrams 2008-01-08 21:23:43 EST
Dom says it looks fine, so...

Note You need to log in before you can comment on or make changes to this bug.