Bug 427951 - SMB/CIFS does not copy files with leading periods in the name
SMB/CIFS does not copy files with leading periods in the name
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 23:30 EST by Marc Schwartz
Modified: 2008-01-08 11:41 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 11:41:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Schwartz 2008-01-07 23:30:26 EST
Description of problem:

When copying files from a local folder to a SMB/CIFS share on a RHEL server
(using Nautilus, Konqueror or via the CLI), files that have a leading period (eg
.emacs) in the file name cannot be copied to the SMB/CIFS share. This occurs
whether one accesses the share via a normal smb:// URL or if the share is
mounted via an entry in /etc/fstab.

It is not clear to me if this is a problem on F8 as the client or on RHEL as the
server or both.

Filenames (and folders) with leading periods are legal on Windows. However, it
is noted that some Windows applications, such as Explorer, will preclude
allowing a user to create or rename a file containing a leading period.

A thread on the Fedora list on this is here:

https://www.redhat.com/archives/fedora-list/2008-January/msg00957.html

The follow up that I will be posting shortly has some references to the MSDN and
Wikipedia with some references on this.


Version-Release number of selected component (if applicable):

samba-3.0.28-0.fc8


How reproducible:

Always


Steps to Reproduce:

With a console window open and with the working directory on the SMB/CIFS share:

$ cp /home/marcs/.emacs .emacs
cp: cannot create regular file `.emacs': No such file or directory

  
Actual results:

See above


Expected results:

A .emacs file (using the above example) should be copied from the local folder
to the target share folder.
Comment 1 Marc Schwartz 2008-01-07 23:40:00 EST
Just a quick follow up with a direct link to the references I mention above in
the Fedora list thread post:

https://www.redhat.com/archives/fedora-list/2008-January/msg01011.html

Thanks.
Comment 2 Simo Sorce 2008-01-08 08:25:26 EST
What samba package do you use on RHEL ?
What client kernel driver are you using? cifs.ko ?

Do you see any error in the logs server side? (raise logs to 5 at least, 10
preferable for the test).
Comment 3 Marc Schwartz 2008-01-08 10:53:35 EST
Simo,

Thanks for your follow up. 

My apologies.

Thanks to Les Mikesell on the Fedora list, who referenced a 'veto' setting in
smb.conf last night, I confirmed with our SysAdmin this morning that indeed:

  veto files = /.*/

appears in the server's smb.conf.

Our SysAdmin commented out that line and reloaded Samba on the server, after
which I could copy these files without issue.  Unfortunately, our SOP's require
this configuration, which our SysAdmin had forgotten about.

So, bottom line, we can close out this bug, which may be of help to others at
some future date.

Thanks again.
Comment 4 Simo Sorce 2008-01-08 11:41:27 EST
No problem, marking as not a bug.

Note You need to log in before you can comment on or make changes to this bug.