Bug 427960 - Grub + Raid + LVM
Grub + Raid + LVM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 02:57 EST by CK
Modified: 2008-01-12 17:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 11:33:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Grub-install result (25.60 KB, text/plain)
2008-01-08 15:14 EST, CK
no flags Details
dmesg result (23.71 KB, text/plain)
2008-01-09 03:47 EST, CK
no flags Details

  None (edit)
Description CK 2008-01-08 02:57:30 EST
I have installed Fedora Core 8 in a machine with 4 disks each 200
  GBytes; sda, sdb, sdc, sdd
 
  the partitioning is the following:
 
  md0: /boot     (Raid-1 (2 disks + 2 spare disks))
  md1: /            (RAID-6, (4 disks) + LVM)
  - the LVM has logical volumes:
    - / for the linux (00)
    - /home the rest (02)
    - swap (01)
 
  When I now start the server it stops without any GRUB menu coming up,
  the error message "GRUB hard disk error" is displayed.
 
  When I start through the linux rescue it works fine. It reads the hard
  disk and no problem when I do the chroot /mnt/sysimage
 
  What is the problem? It seems that the hard disk ctructure can not be
  read by GRUB.
 
  What to do?
 
  Here is the menu.lst :

 boot=/dev/md0
 default=0
 timeout=5
 splashimage=(hd0,0)/grub/splash.xpm.gz
 hiddenmenu
 title Fedora (2.6.23.9-85.fc8)
         root (hd0,0)
         kernel /vmlinuz-2.6.23.9-85.fc8 ro root=/dev/VolGroup00/LogVol00
rhgb quiet
         initrd /initrd-2.6.23.9-85.fc8.img
 title Fedora (2.6.23.1-42.fc8)
         root (hd0,0)
         kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00
rhgb quiet
         initrd /initrd-2.6.23.1-42.fc8.img


 Maybe it is possible to first install the RAID and then on top of md1 put
the LVM
 afterwards.....but it wont be possible I guess.....
 
 What is the actual problem? Why doesn't it play together?

 GRUB doesn't find the hard disks. Any solution.....I can not startup! I am
stuck here!
Comment 1 CK 2008-01-08 15:09:56 EST
I tested to do the following:

1. grub-install /dev/sda1
2. change /dev/md0 in mtab and fstab to /dev/sda1

it did not work, because the /boot could not be found anymore.
Comment 2 CK 2008-01-08 15:14:59 EST
Created attachment 291083 [details]
Grub-install result
Comment 3 CK 2008-01-08 15:19:09 EST
I also tried the following:

grub> root (hd0,0)
grub> setup  --stage2=/boot/grub/stage2 --prefix=/grub (hd0)
...
grub> root (hd1,0)
grub> setup  --stage2=/boot/grub/stage2 --prefix=/grub (hd1)

but it does not help!

Is there anyone who knows the problem?
Comment 4 CK 2008-01-09 03:34:33 EST
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/VolGroup00/LogVol00
                       4062912   2592276   1260924  68% /
/dev/VolGroup00/LogVol02
                     380296124    199472 360466984   1% /home
/dev/md0                194366     19289    165042  11% /boot
Comment 5 CK 2008-01-09 03:35:08 EST
Personalities : [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] 
md0 : active raid1 sda1[0] sdc1[2](S) sdd1[3](S) sdb1[1]
      200704 blocks [2/2] [UU]
      
md1 : active raid6 sda2[0] sdd2[3] sdc2[2] sdb2[1]
      397881344 blocks level 6, 256k chunk, algorithm 2 [4/4] [UUUU]
Comment 6 CK 2008-01-09 03:36:00 EST
[root@localhost ~]# tail /etc/fstab 
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
/dev/VolGroup00/LogVol02 /home                   ext3    defaults        1 2
/dev/md0               /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
Comment 7 CK 2008-01-09 03:47:03 EST
Created attachment 291122 [details]
dmesg result
Comment 8 CK 2008-01-09 03:49:09 EST
[root@localhost ~]# grub-install --recheck /dev/md0
Probing devices to guess BIOS drives. This may take a long time.
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(fd0)   /dev/fd0
(hd0)   /dev/sda
(hd1)   /dev/sdb
(hd2)   /dev/sdc
(hd3)   /dev/sdd
Comment 9 CK 2008-01-09 03:52:44 EST
All above have been done in rescue mode after chroot /mnt/sysimage
Comment 10 CK 2008-01-12 17:16:51 EST
Now I have been looking into an another machine with FC3. It has grub + raid but
not lvm. Boot is /dev/md0 The setup is exactly the same as in the FC8. It works
just fine!!!!

What is the difference? BIOS problem? No, I don't think so as the machines are
exactly the same and have the same BIOS as well as hardware.

My conclusion is that something must have happened with GRUB from FC3 -> FC8

I can not use the machine at all because I can only start it in rescue mode.

Is there anyone who can help me as this is a critical error. I would be thankful
to get some advice.

Note You need to log in before you can comment on or make changes to this bug.