Bug 427964 - mini cleanup of pvm.spec
mini cleanup of pvm.spec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pvm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 04:32 EST by Florian La Roche
Modified: 2008-01-10 01:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 01:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2008-01-08 04:32:11 EST
Description of problem:

--- pvm.spec
+++ pvm.spec
@@ -1,7 +1,7 @@
 Summary: Libraries for distributed computing.
 Name: pvm
 Version: 3.4.5
-Release: 7.fc6.1
+Release: 8%{?dist}
 License: freely distributable
 Group: Development/Libraries
 Source0: http://www.netlib.org/pvm3/pvm%{version}.tgz
@@ -64,6 +64,7 @@ tar -xzf %{SOURCE1}
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+find . -type f -name "*.orig" -exec rm -f {} \;

 # Patch the LINUX*64.def files to look in lib64 dirs as well for libraries.
 perl -p -i -e "s|ARCHDLIB[     \ ]*=|ARCHDLIB  = -L/usr/lib64
-L/usr/X11R6/lib64|" conf/LINUX64.def
@@ -225,6 +226,10 @@ rm -f files.list
 /usr/share/pvm3/xpvm/*

 %changelog
+* Tue Jan 08 2008 Florian La Roche <laroche@redhat.com> - 3.4.5-8
+- do not package *.orig patch files
+- use dist macro
+
 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.4.5-7.fc6.1
 - rebuild




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Lancaster 2008-01-09 03:31:02 EST
Also, pvm needs to be rebuilt on rawhide against the new Tcl 8.5, currently it
has been the broken dep report for almost a week:


        pvm-gui - 3.4.5-7.fc6.1.i386 requires libtk8.4.so
        pvm-gui - 3.4.5-7.fc6.1.i386 requires libtcl8.4.so
 
Is the maintainer active?  The last koji build from this user was back in October:

http://koji.fedoraproject.org/koji/userinfo?userID=14

and this package hasn't been rebuilt since FC-6.
Comment 2 Alex Lancaster 2008-01-09 03:31:40 EST
(Also, if the ACLs weren't locked down, other maintainers could help fix this).
Comment 3 Doug Ledford 2008-01-09 10:21:15 EST
Actually, can't we just kill pvm?  It was long ago supposedly replaced by LAM,
and that was so long ago that LAM has been replaced by openmpi.  I consider pvm
a deprecated (at best) technology.  So, if someone else wants it, they can have
it.  I've more or less got my hands full taking care of openmpi, lam, all
InfiniBand related packages, and all InfiniBand related kernel code.
Comment 4 Alex Lancaster 2008-01-09 11:40:14 EST
If you don't want to maintain you can orphan it via PackageDB and/or allow
cvsextras users to modify the packages (or both), currently nobody else can fix it:

https://admin.fedoraproject.org/pkgdb/packages/name/pvm

I can pick it up and maintain it (at least in the short term).
Comment 5 Doug Ledford 2008-01-09 13:22:02 EST
Thanks for the link.  Package orphaned.
Comment 6 Alex Lancaster 2008-01-10 01:47:17 EST
Patch applied and now built successfully in rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=30973

closing bug.
Comment 7 Alex Lancaster 2008-01-10 01:48:08 EST
Also I opened up ACLs so that package can be fixed any Fedora contributor in the
future...

Note You need to log in before you can comment on or make changes to this bug.