Bug 427966 - OpenOffice.org crashes on close of ftp:// url
OpenOffice.org crashes on close of ftp:// url
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 04:47 EST by Edouard Bourguignon
Modified: 2013-07-02 19:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: 7.17.1-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:09:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to curl (518 bytes, patch)
2008-01-08 08:41 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Edouard Bourguignon 2008-01-08 04:47:14 EST
Description of problem:

OpenOffice crashes on close while editing file accessed thru gnome-vfs (tested
on ftp)

Version-Release number of selected component (if applicable):

openoffice.org-writer-2.3.0-6.7.fc8

How reproducible:
static

Steps to Reproduce:
1. Open your ftp access in Nautilus
2. Open your file
3. Close OpenOffice => "OOo has crashed!"
  
Actual results:

OOo crahes on close, but it seems to occur only on remote files. Same file
copied on the local file system doesn't make OOo crash

(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules//drivers/fglrx_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-33-x86_64 libgcj-4.1.2-33-i386
(V)    kernel is: Linux 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.7.fc8-x86_64
(VII)  accessibility is: false
(VIII) fedora release is: Fedora release 8 (Werewolf)
...start free space details ...
Sys. de fich.        1K-blocs       Occupé Disponible Capacité Monté sur
/dev/sda2            144520596  29921360 107139456  22% /home
/dev/sda5             10153988   6410052   3219820  67% /
...end free space details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x0000003089436a64: 0x00000000001ebbe8:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x36a64
0x000000308943785a: 0x00000000001ebbe8:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x3785a
0x000000360dc0e540: 0x0000000000015da8: /lib64/libpthread.so.0 + 0xe540
0x000000360d061467: 0x0000000000150b60: /lib64/libc.so.6 + 0x61467 (fclose + 0x7)
0x00002aaac05f845d: 0x00000000000304f0:
/usr/lib64/openoffice.org/program/libucpftp1.so + 0x2045d
0x00000030265ad00e: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x1ad00e
(SfxObjectShell::~SfxObjectShell() + 0x18e)
0x000000302ac3c92e: 0x0000000000b8bc28:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x83c92e
(SwDocShell::~SwDocShell() + 0x11e)
0x0000003026663864: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x263864
0x000000302667265e: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x27265e
(SfxTopViewFrame::~SfxTopViewFrame() + 0x3e)
0x0000003026671fde: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x271fde
(SfxTopViewFrame::Close() + 0x3e)
0x00000030266534a3: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x2534a3
0x000000302667cb21: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x27cb21
(SfxBaseController::dispose() + 0x471)
0x0000003029a8b1d6: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0x8b1d6
0x0000003029a89cd8: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0x89cd8
0x0000003029a6bcb2: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0x6bcb2
0x0000003029a6f399: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0x6f399
0x0000003029aba1d3: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0xba1d3
0x0000003029aba6b9: 0x00000000002f4318:
/usr/lib64/openoffice.org/program/libfwk680lx.so + 0xba6b9
0x0000003021d00b1a: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x300b1a
0x0000003021ca7601: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x2a7601
0x00002aaaafa5fc8f: 0x00000000000818b0:
/usr/lib64/openoffice.org/program/libvclplug_gen680lx.so + 0x57c8f
(SalDisplay::DispatchInternalEvent() + 0xbf)
0x00002aaaaf5a3029: 0x000000000004fe68:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x18029
0x000000308362eea3: 0x00000000000c6a98: /lib64/libglib-2.0.so.0 + 0x2eea3
(g_main_context_dispatch + 0x1c3)
0x000000308363219d: 0x00000000000c6a98: /lib64/libglib-2.0.so.0 + 0x3219d
0x00000030836326ce: 0x00000000000c6a98: /lib64/libglib-2.0.so.0 + 0x326ce
(g_main_context_iteration + 0x6e)
0x00002aaaaf5a4ab9: 0x000000000004fe68:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x19ab9
0x0000003021acffce: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xcffce
(Application::Yield(bool) + 0x3e)
0x0000003021ad00a7: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd00a7
(Application::Execute() + 0x27)
0x000000302a02d05e: 0x000000000005b458:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x2d05e
(desktop::Desktop::Main() + 0x13ae)
0x0000003021ad5864: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd5864
0x0000003021ad5955: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd5955 (SVMain() + 0x25)
0x000000302a01f65e: 0x000000000005b458:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x1f65e (main + 0xae)
0x000000360d01e074: 0x0000000000150b60: /lib64/libc.so.6 + 0x1e074
(__libc_start_main + 0xf4)
0x0000000000400639: 0x0000000000000890:
/usr/lib64/openoffice.org/program/swriter.bin + 0x639 (main + 0x49)
...end stackreport details ...
...start sample ldd details ...
	linux-vdso.so.1 =>  (0x00007fffa97fe000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00002aaaaad26000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00002aaaab3d7000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00002aaaab695000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00002aaaab8b4000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00002aaaabad5000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00002aaaabcdf000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00002aaaabf21000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00002aaaac19f000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaac3a2000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00002aaaac5a6000)
	librt.so.1 => /lib64/librt.so.1 (0x00002aaaac7ab000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00002aaaac9b4000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00002aaaacbd3000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00002aaaace0f000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00002aaaad050000)
	libvclplug_gen680lx.so =>
/usr/lib64/openoffice.org/program/libvclplug_gen680lx.so (0x00002aaaad318000)
	libvcl680lx.so => /usr/lib64/openoffice.org/program/libvcl680lx.so
(0x00002aaaad5a3000)
	libpsp680lx.so => /usr/lib64/openoffice.org/program/libpsp680lx.so
(0x00002aaaadb5d000)
	libsot680lx.so => /usr/lib64/openoffice.org/program/libsot680lx.so
(0x00002aaaade4e000)
	libutl680lx.so => /usr/lib64/openoffice.org/program/libutl680lx.so
(0x00002aaaae0b4000)
	libtl680lx.so => /usr/lib64/openoffice.org/program/libtl680lx.so
(0x00002aaaae353000)
	libcomphelp4gcc3.so => /usr/lib64/openoffice.org/program/libcomphelp4gcc3.so
(0x00002aaaae5fe000)
	libucbhelper4gcc3.so => /usr/lib64/openoffice.org/program/libucbhelper4gcc3.so
(0x00002aaaae939000)
	libuno_cppuhelpergcc3.so.3 =>
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0x00002aaaaebb7000)
	libuno_cppu.so.3 => /usr/lib64/openoffice.org/program/libuno_cppu.so.3
(0x00002aaaaee78000)
	libvos3gcc3.so => /usr/lib64/openoffice.org/program/libvos3gcc3.so
(0x00002aaaaf0a8000)
	libuno_sal.so.3 => /usr/lib64/openoffice.org/program/libuno_sal.so.3
(0x00002aaaaf2cf000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaaf6c6000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaaf9cb000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaafbdc000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaafdf7000)
	libm.so.6 => /lib64/libm.so.6 (0x00002aaab00f8000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaab037b000)
	libc.so.6 => /lib64/libc.so.6 (0x00002aaab0589000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00002aaab08e1000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00002aaab0ae3000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00002aaab0ce8000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00002aaab0f0d000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00002aaab1141000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00002aaab134a000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x00002aaab154d000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00002aaab1756000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00002aaab195d000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00002aaab1b67000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00002aaab1d98000)
	libz.so.1 => /lib64/libz.so.1 (0x00002aaab2028000)
	/lib64/ld-linux-x86-64.so.2 (0x000000360be00000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x00002aaab223c000)
	libcap.so.1 => /lib64/libcap.so.1 (0x00002aaab2455000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00002aaab2658000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x00002aaab2862000)
	libi18nisolang1gcc3.so =>
/usr/lib64/openoffice.org/program/libi18nisolang1gcc3.so (0x00002aaab2a7e000)
	libbasegfx680lx.so => /usr/lib64/openoffice.org/program/libbasegfx680lx.so
(0x00002aaab2c83000)
	libicuuc.so.38 => /usr/lib64/libicuuc.so.38 (0x00002aaab2ef0000)
	libicule.so.38 => /usr/lib64/libicule.so.38 (0x00002aaab3228000)
	libjvmaccessgcc3.so.3 =>
/usr/lib64/openoffice.org/program/libjvmaccessgcc3.so.3 (0x00002aaab345d000)
	libjvmfwk.so.3 => /usr/lib64/openoffice.org/program/libjvmfwk.so.3
(0x00002aaab3666000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x00002aaab3882000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaab3a87000)
	libxcb-xlib.so.0 => /usr/lib64/libxcb-xlib.so.0 (0x00002aaab3cbf000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00002aaab3ec1000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaab40dc000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x00002aaab42df000)
	libicudata.so.38 => /usr/lib64/libicudata.so.38 (0x00002aaab4502000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00002aaab51ac000)
	libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaab54eb000)
...end sample ldd details ...

Expected results:

OOo shouldn't crash when you close it.

Additional info:
Comment 1 Caolan McNamara 2008-01-08 05:28:26 EST
Just to attempt to get close to this setup for testing, was it an anonymous ftp
or a username/password one ? And did you have write access to the opened file ?
And did you make any modifications and try and use save, or was it just open it,
read it and then close OOo ?
Comment 2 Caolan McNamara 2008-01-08 08:40:28 EST
I don't get an immediate crash but I do get invalid closes on

valgrind /usr/lib64/openoffice.org/program/soffice.bin
ftp://username:password@somewhere/test.odt from libcurl

and the attached patch to curl makes them go away
Comment 3 Caolan McNamara 2008-01-08 08:41:09 EST
Created attachment 291052 [details]
patch to curl
Comment 4 Jindrich Novy 2008-01-08 09:26:52 EST
Applied, thanks!
Comment 5 Edouard Bourguignon 2008-01-08 09:44:18 EST
it was on an anonymous ftp, no modification on the file, just open and close it.
Comment 6 Fedora Update System 2008-01-24 16:57:09 EST
curl-7.17.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update curl'
Comment 7 Fedora Update System 2008-02-15 21:09:48 EST
curl-7.17.1-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Daniel Stenberg 2008-02-24 09:53:01 EST
Allow me to express my disappointment in you. I've tried to participate and help
and assist in your bug tracker, and as a thank-you you patch and fix curl and
keep the patch "secret" in this way. (Me being the maintainer and primary author
of curl and libcurl "upstream".)

It was only due to a keep user that notified our mailing list that made us aware
of your patch here. This is not a very open-source way of doing things, and you
should know this.
Comment 9 Jindrich Novy 2008-02-25 08:45:00 EST
(In reply to comment #8)
> Allow me to express my disappointment in you. I've tried to participate and help
> and assist in your bug tracker, and as a thank-you you patch and fix curl and
> keep the patch "secret" in this way. (Me being the maintainer and primary author
> of curl and libcurl "upstream".)

It is announced on the first line in changelog in the F8 update (also in the
update release notes) and in rawhide as well. Both F8 and rawhide repositories
are publicly available and to hide the patch in any way was never my intention. Why?

> It was only due to a keep user that notified our mailing list that made us aware
> of your patch here. This is not a very open-source way of doing things, and you
> should know this.

If you wish to be notified about patches going into Fedora for curl:

Please apply for "watchcommits" here:

https://admin.fedoraproject.org/pkgdb/packages/name/curl

after that you will receive all Fedora commits to curl by mail. It is not very
frequent so you won't get spammed. You can also apply for "watchbugzilla" where
you will be in default Cc for all curl bugs reported to me or even "commit" if
you wish to have commit access in Fedora curl.

I can give you approval immediately for all this.

I propose this to you since there exist only curl-users and curl-library mailing
lists. They are for a wide audience and I don't want to receive more spam than
is needed, what is the reason that I'm not subscribed to the lists and don't
contribute to them. In other projects such as Midnight Commander, there exist mc
for general discussion and mc-devel for patches and development
discussion/patches/technical RFEs. It would be nice to see such list for curl
(say curl-devel or curl-patches) and I'd be happy to subscribe/contribute to it
if needed.
Comment 10 Till Maas 2008-08-22 06:05:39 EDT
Regarding upstreaming:

It is best practices[1,2] to send patches within Fedora to upstream and not wait for them to notice them.

It is also mentioned in the Fedora Objectives[3]:

| To do as much of the development work as possible  directly in the upstream 
| packages. We will in general prefer moving to a newer version for updates rather
| than backport fixes.

[1] https://fedoraproject.org/wiki/Packaging/PatchUpstreamStatus
[2] https://fedoraproject.org/wiki/PackageMaintainers/WhyUpstream
[3] https://fedoraproject.org/wiki/Objectives
Comment 11 Warren Togami 2008-08-25 18:08:20 EDT
Jindrich,

The "making available" argument is not good enough.  It is an expectation of Fedora developers to submit patches directly to upstream development projects.

Note You need to log in before you can comment on or make changes to this bug.