Bug 427967 - La aplicación npviewer.bin intentó cargar /usr/lib/mozilla/plugins/nppdf.so que requiere reasignación de texto. Esto es un problema de seguridad potencial.
Summary: La aplicación npviewer.bin intentó cargar /usr/lib/mozilla/plugins/nppdf.so q...
Status: CLOSED DUPLICATE of bug 250249
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-08 09:55 UTC by Pedro Zuccarello
Modified: 2008-01-08 10:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 10:29:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pedro Zuccarello 2008-01-08 09:55:52 UTC
La aplicación npviewer.bin intentó cargar /usr/lib/mozilla/plugins/nppdf.so que
requiere reasignación de texto. Esto es un problema de seguridad potencial. La
mayoría de las bibliotecas no necesitan este permiso. Las bibliotecas son a
veces codificadas incorrectamente y requieren este permiso. La página web de
Pruebas de Protección de Memoria en SELinux explica cómo eliminar este
requerimiento. Puede configurar SELinux para que temporalmente permita a
/usr/lib/mozilla/plugins/nppdf.so usar la reubicación mientras se corrije la
biblioteca. Por favor, ingrese un informe de error contra este paquete.

Contexto Fuente:  system_u:system_r:unconfined_t:s0

Contexto Destino:  system_u:object_r:lib_t:s0

Objetos Destino:  /usr/lib/mozilla/plugins/nppdf.so [ file ]

RPM de Políticas:  selinux-policy-3.0.8-72.fc8

SELinux Activado:  True

Tipo de Política:  targeted

MLS Activado:  True

Modo Obediente:  Enforcing

Nombre de Plugin:  plugins.allow_execmod

Plataforma:  Linux 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007 x86_64 x86_64

Cantidad de Alertas:  14

Local ID:  9b02230c-3203-4526-aa01-46a0fc18edb6

Mensajes de Auditoría Crudos :
avc: denied { execmod } for comm=npviewer.bin dev=sda6
path=/usr/lib/mozilla/plugins/nppdf.so pid=7037
scontext=system_u:system_r:unconfined_t:s0 tclass=file
tcontext=system_u:object_r:lib_t:s0

Comment 1 Martin Stransky 2008-01-08 10:29:18 UTC

*** This bug has been marked as a duplicate of 250249 ***


Note You need to log in before you can comment on or make changes to this bug.