Bug 427976 - LaCie Desktop HDD, 500 GB, appears to be smaller
LaCie Desktop HDD, 500 GB, appears to be smaller
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://www.lacie.com/us/products/prod...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 07:39 EST by Răzvan Sandu
Modified: 2008-04-27 00:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 00:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-01-08 07:39:05 EST
Hello,

Description of problem:

I've tried to use a LaCie 500 GB HDD to perform some mirror-backup with dd
(http://www.lacie.com/us/products/product.htm?pid=10695).

I've tried to obtain a single primary partition of 500 GB on the HDD, on both
Fedora 7 and Fedora 8.

The maximum size of the partition that can actually be obtained is around 46 GB
(/dev/sdb1). Here's the output of fdisk -l:

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1           1         60801   488384001   83  Linux

And here's the output of df -h (the relevant lines are the last two):

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             265G  7,5G  244G   3% /
/dev/sda4             996M   34M  911M   4% /tmp
/dev/sda1             479M   23M  432M   5% /boot
tmpfs                1007M     0 1007M   0% /dev/shm
/dev/sdb1              46G  675M   43G   2% /media/IBM
/dev/sr0              197M  197M     0 100% /media/LaCie_Storage



Version-Release number of selected component (if applicable):
util-linux-2.13-0.54.1.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Connect USB HDD according to manual and power it on.
2. Using fdisk on the empty HDD, try to create a single primary partition of 500 GB.
3. Note that a partition no larger than 46 GB is created.
  
Actual results:
A partition no larger than 46 GB is created.

Expected results:
Partition should be as large as the HDD is.

Additional info:
Comment 1 Karel Zak 2008-01-10 07:56:27 EST
It doesn't seem like a problem in fdisk(8). Did you try to use any other tool,
for example parted or sfdisk? Any error message, dmesg?

Did you try to create two partitions? What if you create a small sdb1 and a huge
sdb2? Is it possible?

It seems you are not alone with this problem, see for example
http://wl500g.info/showthread.php?t=4039#5
Comment 2 Chuck Ebbert 2008-01-10 15:41:46 EST
That's weird. It is limiting the disk to the size of (sectors * heads)
Comment 3 Răzvan Sandu 2008-01-10 16:00:22 EST
Hello,

Just to say that I've managed to create a partition of 460+ GB using Fedora's
gparted.

Regards,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.