Bug 428001 - Yelp does not compile against xulrunner
Yelp does not compile against xulrunner
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 434316 (view as bug list)
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2008-01-08 11:50 EST by Bastien Nocera
Modified: 2013-01-09 23:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 10:20:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-01-08 11:50:18 EST
yelp-2.21.2-1.fc9

http://koji.fedoraproject.org/koji/taskinfo?taskID=334597

The pkgconfig file changes in xulrunner are mentioned in:
http://fedoraproject.org/wiki/Releases/FeatureXULRunnerAPIChanges
Comment 1 Matthew Barnes 2008-01-09 15:46:52 EST
I got the pkg-config checks fixed up but I'm getting this compilation error with
xulrunner-devel-1.9-0.beta2.7.fc9.i386, which leads to other errors.

In file included from /usr/include/xulrunner-sdk-1.9pre/gfx/nsMargin.h:41,
                 from
/usr/include/xulrunner-sdk-1.9pre/widget/nsIPrintSettings.h:17,
                 from Yelper.cpp:44:
/usr/include/xulrunner-sdk-1.9pre/gfx/nsCoord.h:42:25: error: nsMathUtils.h: No
such file or directory
Comment 2 Matthew Barnes 2008-02-22 23:23:07 EST
Still fails to build.  Reassigning this to xulrunner maintainers and raising
severity.
Comment 3 Matthew Barnes 2008-02-22 23:25:48 EST
*** Bug 434316 has been marked as a duplicate of this bug. ***
Comment 4 Martin Stransky 2008-02-26 06:44:01 EST
Taking the bug.
Comment 5 Martin Stransky 2008-02-28 10:20:09 EST
fixed in yelp-2.21.90-4.fc9

Note You need to log in before you can comment on or make changes to this bug.