Bug 428013 - Split gnome-pirut from pirut
Split gnome-pirut from pirut
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 12:46 EST by Robin Norwood
Modified: 2008-05-28 15:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to spec file to split out gnome-pirut (2.87 KB, patch)
2008-01-08 12:46 EST, Robin Norwood
no flags Details | Diff

  None (edit)
Description Robin Norwood 2008-01-08 12:46:27 EST
Since several applications are importing the pirut's python modules as a
library, it might be nice to split pirut into a core rpm and a gnome-pirut rpm.
 We could also use this to have an alternate packaging system (ie, PackageKit),
without having to rewrite bits of anaconda right away.

(This would also make it easier to have a KDE interface at some point)
Comment 1 Robin Norwood 2008-01-08 12:46:27 EST
Created attachment 291072 [details]
Patch to spec file to split out gnome-pirut
Comment 2 Matthias Clasen 2008-01-09 12:03:32 EST
Some patch review that I gave Robin on irc already:

The excludes are not necessary, I think. 
Comment 3 Bug Zapper 2008-05-14 00:20:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 petrosyan 2008-05-21 12:20:42 EDT
pirut has been removed from Fedora 9, changing version field to Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.