Bug 428027 - multimedia keys broke in gnome
multimedia keys broke in gnome
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 14:42 EST by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 23:10:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 165343 None None None Never

  None (edit)
Description Bill Nottingham 2008-01-08 14:42:30 EST
Description of problem:

Multimedia keys (next/previous, play, pause, stop) are broken in totem and
rhythmbox. If I go into the keyboard shortcuts menu and attempt to set them,
they are set to the same values they were before when I hit the keys, so the
keys appear to still be generating the same keysym.

Version-Release number of selected component (if applicable):

control-center-2.21.4-2.fc9

How reproducible:

Every time.
Comment 1 Bastien Nocera 2008-01-08 14:49:43 EST
(In reply to comment #0)
> Description of problem:
> 
> Multimedia keys (next/previous, play, pause, stop) are broken in totem and
> rhythmbox. If I go into the keyboard shortcuts menu and attempt to set them,
> they are set to the same values they were before when I hit the keys, so the
> keys appear to still be generating the same keysym.

We don't change the keysyms anymore, because it was even more broken. What do
you mean by "don't work"?
Comment 2 Bill Nottingham 2008-01-08 15:00:06 EST
Nothing happens when they're pressed.

Are you saying the shortcut prefs are ignored?
Comment 3 Bastien Nocera 2008-01-08 15:19:43 EST
(In reply to comment #2)
> Nothing happens when they're pressed.
> 
> Are you saying the shortcut prefs are ignored?

The shortcut prefs are handled by the D-Bus service in gnome-settings-daemon.

Please check whether the output of "dbus-monitor --session --monitor" shows the
key presses appearing, for example:

signal sender=:1.1 -> dest=(null destination) path=/org/gnome/SettingsDaemon;
interface=org.gnome.SettingsDaemon; member=MediaPlayerKeyPressed
   string "Rhythmbox"
   string "Pause"
Comment 4 Bill Nottingham 2008-01-08 16:38:17 EST
Pressing the keys shows nothing in dbus-monitor.
Comment 5 Ray Strode [halfline] 2008-01-11 11:30:02 EST
Theory from Bastien is it broke from the patch in

http://bugzilla.gnome.org/show_bug.cgi?id=165343

Comment 6 Rene Rask 2008-02-14 20:04:02 EST
On my system totem works with multimedia keys, but rhythmbox does not. This is
on fedora alhpa 1 with all updates applied.

With Rhtyhmbox running i get this:

signal sender=:1.1 -> dest=(null destination)
path=/org/gnome/SettingsDaemon/MediaKeys;
interface=org.gnome.SettingsDaemon.MediaKeys; member=MediaPlayerKeyPressed
   string ""
   string "Play"

And with totem running instead I get this:

signal sender=:1.1 -> dest=(null destination)
path=/org/gnome/SettingsDaemon/MediaKeys;
interface=org.gnome.SettingsDaemon.MediaKeys; member=MediaPlayerKeyPressed
   string "Totem"
   string "Play"
method call sender=:1.40 -> dest=:1.3 path=/org/gnome/ScreenSaver;
interface=org.gnome.ScreenSaver; member=Inhibit
   string "Totem"
   string "Playing a movie"
method return sender=:1.3 -> dest=:1.40 reply_serial=33
   uint32 1972705658

I have special keys on the keyboard for play,next,previous so there are no keys
like "Fn" involved.
Comment 7 Ray Strode [halfline] 2008-02-15 09:07:38 EST
Bill, is your experience consistent with that in current rawhide?
Comment 8 Matthias Clasen 2008-02-15 09:20:14 EST
Note that the patch Ray mentioned in comment #5 has been reverted in the
gnome-settings-daemon version we have in rawhide, so if it works again, thats why.
Comment 9 Bill Nottingham 2008-02-15 10:25:29 EST
Yes, totem works, rhythmbox does not.
Comment 10 Matthias Clasen 2008-02-18 22:27:50 EST
Look at the plugins in rhythmbox and totem:

rhythmbox:
                plugin->proxy = dbus_g_proxy_new_for_name (bus,
                                "org.gnome.SettingsDaemon.MediaKeys",
                                "/org/gnome/SettingsDaemon/MediaKeys",
                                "org.gnome.SettingsDaemon.MediaKeys");

totem:
        pi->media_player_keys_proxy = 
          dbus_g_proxy_new_for_name_owner (connection,
                                                "org.gnome.SettingsDaemon",
                                               
"/org/gnome/SettingsDaemon/MediaKeys",
                                                "org.gnome. n.MediaKeys",
                                                 NULL);

and indeed, debug output from a rhythmbox launch has:

(22:24:57) [0x900a478] [impl_activate] rb-mmkeys-plugin.c:286: activating media
player keys plugin
(22:24:57) [0x900a478] [impl_activate] rb-mmkeys-plugin.c:339:
org.gnome.SettingsDaemon.MediaKeys dbus service not found

Comment 11 Matthias Clasen 2008-02-18 23:10:27 EST
Should be fixed in rhythmbox-0.11.4-9.fc9

Note You need to log in before you can comment on or make changes to this bug.