Bug 428028 - samba 3.0.25b breaks rebuilds of stock RHEL4 packages
samba 3.0.25b breaks rebuilds of stock RHEL4 packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Simo Sorce
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 14:45 EST by Jack Neely
Modified: 2008-07-24 15:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0711
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild log of gnome-vfs2 (404.25 KB, text/plain)
2008-01-08 14:45 EST, Jack Neely
no flags Details
fix libsmbclient api change (4.01 KB, patch)
2008-01-09 09:02 EST, Simo Sorce
no flags Details | Diff

  None (edit)
Description Jack Neely 2008-01-08 14:45:55 EST
Description of problem:
While working with the gnome-vsf2-2.8.2-8.6.EL4 package I was unable to get the
package, without modification, to rebuild on a current RHEL 4.6 box.

It came down to the newer samba packages have some API bits that are no longer
present that gnome-vsf2 requires.  I downgraded samba to samba-3.0.10-1.4E.12.2
and I was able to successfully rebuild the stock version of gnome-vfs2.

Does this affect and of the functionality of Gnome VFS on SMB shares?
Comment 1 Jack Neely 2008-01-08 14:45:55 EST
Created attachment 291080 [details]
rpmbuild log of gnome-vfs2
Comment 2 Simo Sorce 2008-01-09 08:30:23 EST
The structure entry was renamed close_fn during the dev cycle.
The structure is still ABI compatible so you will not have problems running the
compiled packages with newer versions. 

I will see to provide a fix for this.
Comment 3 Simo Sorce 2008-01-09 09:02:13 EST
Created attachment 291152 [details]
fix libsmbclient api change

This patch should fix this problem.
Comment 4 RHEL Product and Program Management 2008-02-14 16:38:12 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:54:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0711.html

Note You need to log in before you can comment on or make changes to this bug.