Bug 428043 - VT switch is broken, hangs box
VT switch is broken, hangs box
Status: CLOSED DUPLICATE of bug 428813
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 16:30 EST by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 08:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log when crashed with 'Ctl-Alt-F7' (17.20 KB, application/x-gzip)
2008-01-10 10:18 EST, Tom London
no flags Details
Xorg.0.log from vt switch (26.11 KB, text/plain)
2008-01-24 17:42 EST, Zack Cerza
no flags Details
Xorg.0.log from enabling compiz (23.98 KB, text/plain)
2008-01-24 17:44 EST, Zack Cerza
no flags Details
backtrace from enabling compiz (5.01 KB, application/octet-stream)
2008-01-24 17:44 EST, Zack Cerza
no flags Details
/var/log/messages from enabling compiz (733 bytes, text/plain)
2008-01-24 17:45 EST, Zack Cerza
no flags Details

  None (edit)
Description Bill Nottingham 2008-01-08 16:30:06 EST
Description of problem:

You appear to be able to switch VTs once; once you switch back to X, you get a
black screen, the screen blanks a few times, and then the box is hung.

Disabling DRI fixes it.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.1-0.14.fc9
xorg-x11-drv-i810-2.2.0-2.fc9
Comment 1 Matěj Cepl 2008-01-10 07:18:37 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Tom London 2008-01-10 10:18:26 EST
Created attachment 291291 [details]
Xorg.0.log when crashed with 'Ctl-Alt-F7'

I can verify this......

I attach Xorg.0.log when this crashed.

I had started system in 'runlevel 3', logged in, and brought up graphical
environment using 'startx'.

'Ctl-Alt-F1' works to bring up text console, but 'Ctl-Alt-F7' does bad things:
random appearing pattern on completely unresponsive screen/system.

Had to powercycle.
Comment 3 Tom London 2008-01-10 10:36:18 EST
Also can confirm that turning off DRI in xorg.conf makes this work.
Comment 4 Zack Cerza 2008-01-24 17:42:56 EST
Created attachment 292873 [details]
Xorg.0.log from vt switch

Here's my Xorg log of the same thing.
Comment 5 Zack Cerza 2008-01-24 17:44:08 EST
Created attachment 292874 [details]
Xorg.0.log from enabling compiz

Here's an X log from a very similar crash while enabling compiz. This looks
like the same issue, even. If not, I can file it separately.
Comment 6 Zack Cerza 2008-01-24 17:44:41 EST
Created attachment 292875 [details]
backtrace from enabling compiz

Here's the backtrace I got when I enabled compiz. This goes with the log posted
just now.
Comment 7 Zack Cerza 2008-01-24 17:45:40 EST
Created attachment 292876 [details]
/var/log/messages from enabling compiz

Here is what happened in /var/log/messages when I enabled compiz. Again, goes
with the log and backtrace just posted.
Comment 8 Zack Cerza 2008-01-24 17:47:31 EST
Taking off the NEEDINFO. If this is the same crash, which I think it is, that
might help a bit.
Comment 9 Matěj Cepl 2008-01-25 08:46:11 EST
Disabling DRI looks awfully like that you may join the part which is now hot at
bug 428813 (I see zack, that you are already there).

*** This bug has been marked as a duplicate of 428813 ***

Note You need to log in before you can comment on or make changes to this bug.