Bug 428078 - Section "DRI" mode 0666 not affect to /dev/dri/card0 mode
Section "DRI" mode 0666 not affect to /dev/dri/card0 mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 22:22 EST by denis ivanov
Modified: 2008-01-30 17:27 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-Xorg-1.4.99.1-0.19.20080107.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 17:27:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.conf (generated automatically by X without config) (2.36 KB, text/plain)
2008-01-14 21:32 EST, denis ivanov
no flags Details

  None (edit)
Description denis ivanov 2008-01-08 22:22:54 EST
Description of problem:

Section "DRI"
        Mode         0666
EndSection

Doesn't change mode of DRI device. glxgears failed with "permission denied
error". Temporary solved by changin mode from root user before starting of X server.

Xorg.0.log seems no errors!


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.1-0.13.fc9
xorg-x11-drv-i810-2.2.0-2.fc9
kernel 2.6.23.1 (yeah not latest)


Additional info:

fc8's X server set mode with same xorg.conf without any problems
Comment 1 denis ivanov 2008-01-14 16:02:18 EST
kernel-2.6.24-0.150.rc7.git4.fc9
xorg-x11-server-Xorg-1.4.99.1-0.15.20080107.fc9
xorg-x11-drv-i810-2.2.0-3.fc9

The same problem:

Section "DRI"
        Mode         0666
EndSection

crw------- 1 root root 226, 0 Jan 14 22:30 /dev/dri/card0
Comment 2 Matěj Cepl 2008-01-14 18:59:57 EST
Weird -- looks like duplicate of bug 245398, but that one is for F7.
Comment 3 denis ivanov 2008-01-14 21:30:57 EST
Just run strace to check what X server does with /dev/dri/card0...

strace -f X 2>&1|grep /dev/dri/

open("/dev/dri/card0", O_RDWR|O_LARGEFILE) = 13
open("/dev/dri/card0", O_RDWR|O_LARGEFILE) = 13
open("/dev/dri/card0", O_RDWR|O_LARGEFILE) = 13
open("/dev/dri/card0", O_RDWR|O_LARGEFILE) = 14
open("/dev/dri/card0", O_RDWR|O_LARGEFILE) = 14

No chmod calls...

If you want try this way please use remote shell because X under strace is very
slow.

Parts of my config:

$cat /etc/X11/xorg.conf |grep -C2 666

Section "DRI"
        Mode         0666
EndSection

$ ls -l /dev/dri/card0 
crw------- 1 root root 226, 0 Jan 15 04:17 /dev/dri/card0

$ glxinfo |grep -i DRM # non-root
libGL error: open DRM failed (Operation not permitted)

# glxinfo |grep direct # from root
direct rendering: Yes
Comment 4 denis ivanov 2008-01-14 21:32:11 EST
Created attachment 291671 [details]
my xorg.conf (generated automatically by X without config)
Comment 5 denis ivanov 2008-01-24 04:44:04 EST
as temporary bugfix i use crontab to update mode of /dev/dri/card0 every minute...
Comment 6 denis ivanov 2008-01-30 17:27:05 EST
Updated rawhide:

xorg-x11-server-Xorg-1.4.99.1-0.19.20080107.fc9.i386
xorg-x11-drv-i810-2.2.0-3.fc9.i386
kernel-2.6.24-9.fc9.i686

Seems the problem is fixed right now
But I even don't know who fix and which package was fixed. ;-)

Tested with Mode 0666, Mode 0644, Mode 0466 etc. All ok.

Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.