Bug 428117 - vncviewer aborts when maximising on wide display (wsxga+ 1680x1050)
vncviewer aborts when maximising on wide display (wsxga+ 1680x1050)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 06:33 EST by Bryn M. Reeves
Modified: 2013-04-30 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 09:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vncviewer core (8.06 MB, application/octet-stream)
2008-03-13 19:10 EDT, Bryn M. Reeves
no flags Details

  None (edit)
Description Bryn M. Reeves 2008-01-09 06:33:21 EST
Description of problem:
When maximising the vncviewer on a client system having a 1680x1050 display,
viewing a remote system with a 1600x1200 desktop size the vncviewer aborts:

$ vncviewer :1

VNC Viewer Free Edition 4.1.2 for X - built Oct 23 2007 13:44:34
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Wed Jan  9 10:50:40 2008
 CConn:       connected to host localhost port 5901
 CConnection: Server supports RFB protocol version 3.7
 CConnection: Using RFB protocol version 3.7

Wed Jan  9 10:50:41 2008
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding

Wed Jan  9 10:50:47 2008
 CConn:       Throughput 20000 kbit/s - changing to hextile encoding
 CConn:       Throughput 20000 kbit/s - changing to full colour
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using hextile encoding

Wed Jan  9 10:50:49 2008
 CConn:       Throughput 1166 kbit/s - changing to ZRLE encoding
 CConn:       Using ZRLE encoding
vncviewer: TXScrollbar.cxx:47: void TXScrollbar::set(int, int, int, bool):
Assertion `limit_ > 0 && len_ >= 0 && len_ <= limit_' failed.
Aborted (core dumped)


Version-Release number of selected component (if applicable):
vnc-4.1.2-23.fc9

How reproducible:
100%

Steps to Reproduce:
1. Start vncviewer on a wide screen system
2. Maximise the vncviewer window

  
Actual results:
vncviewer: TXScrollbar.cxx:47: void TXScrollbar::set(int, int, int, bool):
Assertion `limit_ > 0 && len_ >= 0 && len_ <= limit_' failed.
Aborted (core dumped)


Expected results:
Window maximises.

Additional Info:

Program received signal SIGABRT, Aborted.
0x0000003b17e311a5 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003b17e311a5 in raise () from /lib64/libc.so.6
#1  0x0000003b17e32c50 in abort () from /lib64/libc.so.6
#2  0x0000003b17e2a32f in __assert_fail () from /lib64/libc.so.6
#3  0x000000000041b8ef in TXScrollbar::set (this=<value optimized out>, 
    limit_=<value optimized out>, start_=<value optimized out>, 
    len_=<value optimized out>, vert=false) at TXScrollbar.cxx:47
#4  0x0000000000419315 in TXViewport::resizeNotify (this=0x8480a0)
    at TXScrollbar.h:52
#5  0x000000000041aa1f in TXWindow::handleXEvent (this=0x4bc1, ev=0x4bc1)
    at TXWindow.cxx:395
#6  0x000000000041ae3f in TXWindow::handleXEvents (dpy=0x826a90)
    at TXWindow.cxx:114
#7  0x0000000000407170 in CConn::blockCallback (this=0x7fff83287d60)
    at CConn.cxx:168
#8  0x0000003b1704dceb in rdr::FdInStream::readWithTimeoutOrCallback (
    this=<value optimized out>, buf=<value optimized out>, 
    len=<value optimized out>, wait=<value optimized out>)
    at FdInStream.cxx:217
#9  0x0000003b1704e03f in rdr::FdInStream::overrun (
    this=<value optimized out>, itemSize=<value optimized out>, 
    nItems=<value optimized out>, wait=<value optimized out>)
    at FdInStream.cxx:132
#10 0x00000000004158cb in main (argc=2, argv=0x7fff8328a888)
---Type <return> to continue, or q <return> to quit---
    at ../../common/rdr/InStream.h:48
#11 0x0000003b17e1e1c4 in __libc_start_main () from /lib64/libc.so.6
#12 0x0000000000406999 in _start ()
Comment 1 Adam Tkac 2008-03-13 11:33:55 EDT
Would it be possible attach produced core file, please?
Comment 2 Bryn M. Reeves 2008-03-13 19:03:49 EDT
Sure, but I'll need to do it on a clean account etc - marking this NEEDINFO in
the interrim.
Comment 3 Bryn M. Reeves 2008-03-13 19:10:06 EDT
Created attachment 297998 [details]
vncviewer core
Comment 4 Adam Tkac 2008-03-14 08:20:46 EDT
Patch is commited in CVS and will be in next build
Comment 5 Bryn M. Reeves 2008-03-14 08:49:12 EDT
Thanks Adam! Just reloaded the bug to say "oh, this code doesn't handle the case
where we need a Y scrollbar but not an X", but I see you're far ahead of me!

Just doing a test build here but the patch looks good - thanks again! (This has
bugged me since FC6 but not enough to file the bug until recently).
 
Comment 6 Bryn M. Reeves 2008-03-14 09:05:44 EDT
Verified the patch in CVS - works great, thanks!
Comment 7 Adam Tkac 2008-03-14 09:10:37 EDT
Thanks for your testing. Closing

Note You need to log in before you can comment on or make changes to this bug.