Bug 428119 - slab error in kmem_cache_destroy(): cache `dlm_conn': Can't free all objects
Summary: slab error in kmem_cache_destroy(): cache `dlm_conn': Can't free all objects
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.3
Hardware: All Linux
high
high
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-09 11:55 UTC by Christine Caulfield
Modified: 2009-09-03 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 17:07:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix (352 bytes, patch)
2008-01-10 08:52 UTC, Christine Caulfield
no flags Details | Diff

Description Christine Caulfield 2008-01-09 11:55:33 UTC
Description of problem:

Systems often display this message at shutdown:
"slab error in kmem_cache_destroy(): cache `dlm_conn': Can't free all objects"

Version-Release number of selected component (if applicable):
Probably since 5.2


How reproducible:
Easily.

Steps to Reproduce:
1. Start up cluster with clvmd. 3 nodes for preference
2. Shutdown some nodes
  
Actual results:
one or more nodes will display the above message

it gets worse...
If you stop all DLM lockspaces and attempt to restart them you get that
message plus

"kmem_cache_create: duplicate cache dlm_conn"

and the DLM won't start. this needs a node reboot.

Expected results:
The DLM should shut down cleanly.

Additional info:

This is because the ->othercon structures are not being freed. With all the
othercon patching that went on a while ago it seems like a bit of the patch has
got lost.

Comment 1 Christine Caulfield 2008-01-10 08:52:41 UTC
Created attachment 291245 [details]
Patch to fix

This patch has been sent to Steve for inclusion upstream.

Comment 2 Kiersten (Kerri) Anderson 2008-01-17 16:39:21 UTC
Proposing for inclusion in 5.2 release.  Patch available and will affect
customers who are trying to stop and start the clusters.

Comment 3 Christine Caulfield 2008-01-17 17:07:19 UTC
Closing this bug as the patch was only missing from upstream (and is now
included there). 


Note You need to log in before you can comment on or make changes to this bug.