Bug 428154 - FAT32 file corruption
FAT32 file corruption
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 12:35 EST by RevRagnarok
Modified: 2009-01-09 00:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RevRagnarok 2008-01-09 12:35:05 EST
Description of problem:
I have a dual-boot Dell XPS M1710. I rebooted from WinXP Pro to F8 as usual. I
have a large FAT32 shared drive (/dev/sda6) that is mounted as /data in Linux.

I launched VMWare Player and it said that it could not open the files because
the file system was read-only. I remounted it, and again, same error. Some
Google-Fu revealed that I should check /var/log/messages (paraphrasing sorry):

FAT: Filesystem panic (dev sda6)
  fat_free_clusters: deleting FAT entry beyond EOF
  Filesystem has been set read-only.

I rebooted and had Windows' chkdsk check it, and it ended up truncating a few
files. I booted back to F8 and then instead of risking my VM machine going poof,
went into a scratch directory and copied some code there. I was able to do
"make" once, on the second run, again the filesystem went r/o with the same
error in the main log. So went back to Windows, had it chkdsk again, fixed it,
and then rebooted into 2.6.23.8-63. The scratch directory seemed OK for like 30
"make clean; sync; sync; sync; make; sync; sync; sync" iterations, and I had
made a copy of the VM under Windows, so tried that. Everything seems rock solid
again.

Version-Release number of selected component (if applicable):
2.6.23.9-85.fc8
NOTE: 2.6.23.8-63.fc8 seems FINE

How reproducible:
Not really all that willing to keep risking; it's a work machine.

Steps to Reproduce:
1. Boot into 2.6.23.9-85.fc8 from grub
2. Do a lot of disk activity on FAT32 drive
3.
  
Actual results:
File system corruption.

Expected results:
No file system corruption.

Additional info:
As far as I know, everything else was the same - the wireless was disabled, and
no external USB/FireWire devices.
Comment 1 RevRagnarok 2008-01-16 17:32:06 EST
I'm surprised nobody has said anything about this.

Anyway, it looks like it may have happened again today, this time under the
previous kernel 2.6.23.8-63.fc8. I have been safely using that for a week, but
now all the files I had edited are saying "The file or directory is corrupted
and unreadable."

It looks like I've now lost a full days work. This cannot be good.
Comment 2 RevRagnarok 2008-02-05 18:47:39 EST
Well, http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.23.14 looked
promising. It seemed to work for most of the day. But then the weirdest thing
happened when I rebooted into WinXP. I was editing a bunch of source files that
are under svn control. When I booted back to Windows, it was able to read the
files fine, but they were the OLD files from before I had rebooted! svn said the
files had no changes; I made sure to have it cleanup and rescan the files. I
rebooted thinking maybe I was working in another directory. No, under Linux "svn
diff" showed my changes. So I rebooted again and forced a chkdsk. Now the
Windows side sees the new files, and the recovered lost chains are all the
original files. So I am guessing that the two sides aren't looking at the same
FAT tables or something???
Comment 3 Bug Zapper 2008-11-26 04:21:37 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-01-09 00:44:56 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.