Bug 428172 - HPLIP USB printer device has wrong permissions; documents do not print
HPLIP USB printer device has wrong permissions; documents do not print
Status: CLOSED DUPLICATE of bug 424331
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 14:25 EST by Russell Odom
Modified: 2008-01-10 04:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 04:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2008-01-09 14:25:19 EST
Description of problem:
I have just bought a new HP printer - a PhotoSmart D7160. I've installed the
hplip driver and GUI and all worked fine - the printer was detected, installed,
and I can see its status, print a calibration page, etc. However, I cannot print
a test page or a normal document; instead the job just sits in the queue and
messages like the following are in /var/log/messages (every 30 secs):
Jan  9 17:21:10 detritus Photosmart_D7100_series?serial=MY737F11DM04SF:
io/hpmud/musb.c 549: invalid product id string: Operation not permitted
Jan  9 17:21:10 detritus Photosmart_D7100_series?serial=MY737F11DM04SF:
io/hpmud/musb.c 1003: unable to open
hp:/usb/Photosmart_D7100_series?serial=MY737F11DM04SF
Jan  9 17:21:10 detritus Photosmart_D7100_series?serial=MY737F11DM04SF: INFO:
open device failed; will retry in 30 seconds...

On investigation it seems to be a permissions problem for the USB device; I can
make printing work by changing the permissions as follows:
[root@detritus ~]# lsusb | grep 03f0
Bus 001 Device 011: ID 03f0:c602 Hewlett-Packard 
[root@detritus ~]# ls -l /dev/bus/usb/001/011 
crw-r--r--+ 1 root lp 189, 10 2008-01-09 18:46 /dev/bus/usb/001/011
root@detritus ~]# chmod go+w /dev/bus/usb/001/011
[root@detritus ~]# ls -l /dev/bus/usb/001/011
crw-rw-rw-+ 1 root lp 189, 10 2008-01-09 18:46 /dev/bus/usb/001/011

After doing this, the queued documents print fine. This is obviously a dirty
hack and needs repeating every time the printer is powered on, and giving
world-write permission to the device isn't ideal. I could add my user to the lp
group and just make it group-writable, which would be an improvement in security
terms. However, my old printer (HP DeskJet 640C) didn't need this, so I'm not
sure whether changing the permissions here is the right fix.

Version-Release number of selected component (if applicable):
[root@detritus ~]# rpm -q hplip hplip-gui hpijs udev 
hplip-2.7.7-6.fc8.x86_64
hplip-gui-2.7.7-6.fc8.x86_64
hpijs-2.7.7-6.fc8.x86_64
udev-116-3.fc8.x86_64
[root@detritus ~]# uname -a
Linux detritus.local 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007 x86_64
x86_64 x86_64 GNU/Linux

How reproducible:
Every time

Steps to Reproduce:
1. Plug printer in, set it up, verify hp-toolbox can see the printer status
2. Print a test page from hp-toolbox or another app
  
Actual results:
Job just sits in the queue forever; messages as above

Expected results:
Job should print!
Comment 1 Tim Waugh 2008-01-10 04:07:26 EST

*** This bug has been marked as a duplicate of 424331 ***

Note You need to log in before you can comment on or make changes to this bug.