Bug 428181 - Need EAP-FAST (RFC 4851) support
Need EAP-FAST (RFC 4851) support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openssl (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Tomas Mraz
Miroslav Vadkerti
: FutureFeature, Reopened
Depends On:
Blocks: 209339 428184
  Show dependency treegraph
 
Reported: 2008-01-09 15:26 EST by Dan Williams
Modified: 2010-11-15 09:33 EST (History)
8 users (show)

See Also:
Fixed In Version: openssl-0.9.8k-7.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:33:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch exposing functionality that wpa_supplicant needs for EAP-FAST (14.66 KB, patch)
2008-01-09 15:26 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Dan Williams 2008-01-09 15:26:30 EST
I can't enable EAP-FAST support in wpa_supplicant (which is needed for
NetworkManager to support EAP-FAST) unless we apply Jouni's OpenSSL patch.  It's
been around for quite a while but upstream never seems to comment on it.  The
upstream openssl issue is:

http://rt.openssl.org/index.html?q=1574

There's a patch in wpa_supplicant git that applies to openssl 0.9.8 too,
attached here.  Thoughts?
Comment 1 Dan Williams 2008-01-09 15:26:30 EST
Created attachment 291197 [details]
Patch exposing functionality that wpa_supplicant needs for EAP-FAST
Comment 2 RHEL Product and Program Management 2008-01-09 15:35:43 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 16 RHEL Product and Program Management 2008-06-04 18:47:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 25 Tomas Mraz 2008-09-30 15:59:01 EDT
Unfortunately no news from upstream. And I don't want to commit to adding the non-upstream patch.
Comment 26 Bill Nottingham 2008-09-30 16:05:04 EDT
Closing then. We can reconsider if upstream takes the patch.
Comment 27 Bill Nottingham 2008-10-09 16:28:46 EDT
*** Bug 209339 has been marked as a duplicate of this bug. ***
Comment 29 James G. Brown III 2008-11-16 20:25:22 EST
Finally, this was applied to HEAD

rt for the issue http://rt.openssl.org/index.html?q=1574

http://cvs.openssl.org/fileview?f=openssl/CHANGES&v=1.1457

2008-Nov-15 18:18 	    1.1457    	Check-in [17641]: PR: 1574 Submitted by: Jouni Malinen <j@w1.fi> Approved by: steve@openssl.org

Ticket override support for EAP-FAST. By steve. (diff) 

Changes can be viewed here

http://cvs.openssl.org/chngview?cn=17641
Comment 30 Dan Williams 2008-11-17 10:26:10 EST
Whee!  Now we can potentially add support to NM too, though how exactly we auto-detect whether openssl was built with EAP-FAST, and thus whether wpa_supplicant supports it, is anyone's guess...
Comment 31 Tomas Mraz 2008-11-26 08:24:52 EST
Do you need build-time or run-time autodetection?
Comment 32 Dan Williams 2008-11-26 10:54:14 EST
(In reply to comment #31)
> Do you need build-time or run-time autodetection?

runtime; but wpa_supplicant has the facility to report the EAP methods it supports, so I think we're OK here.  Basically, we build OpenSSL with EAP-FAST support, build wpa_supplicant with EAP-FAST support against that OpenSSL, and then NetworkManager will runtime-query the supplicant to determine if EAP-FAST is available.

Of course, this doesn't solve the issue where, in the connection editor, you can always configure an EAP-FAST connection even if the computer you're currently on doesn't support it.  But that's the same as if you have an old wifi card that doesn't support WPA, you should still be able to make a WPA connection and use that with a WPA capable card later.  We just need better error reporting here so that when you do try to activate an EAP-FAST connection on a machine that isnt' built with EAP-FAST support, you get (a) can't and (b) get a message to that effect.
Comment 34 Tomas Mraz 2008-12-08 14:37:59 EST
I plan to make package with the upstream patch backported to Fedora 11. It will require a SONAME bump though.
Comment 35 Jason Roysdon 2008-12-08 16:19:33 EST
Support is missing in F9 and F10 as well for EAP-FAST.
Comment 36 Bill Nottingham 2008-12-08 16:54:20 EST
Yes, the patch only went upstream in the past few weeks.
Comment 37 Tomas Mraz 2008-12-09 03:16:02 EST
Unfortunately it breaks ABI so it is not possible to push the patch to F9,10.
Comment 38 Tomas Mraz 2009-01-15 05:26:12 EST
I've backported the patch from 0.9.9 branch to the 0.9.8j which is now in rawhide.
Comment 43 Jason Roysdon 2010-02-04 12:09:06 EST
(In reply to comment #42)
> Fixed in 'openssl-0.9.8k-7.el6', included in compose 'RHEL6.0-20091102.0'.
> Moving to ON_QA.    

If QA has a problem testing this, if this could be made available to me, I would be willing to test it with an existing client network using EAP-FAST.
Comment 47 Miroslav Vadkerti 2010-04-28 01:54:34 EDT
Jason, we lack infrastructure currently to test this bug properly. As RHEL6 Beta is public, could you please help us test this issue?
Comment 48 Miroslav Vadkerti 2010-06-01 05:23:45 EDT
We lack infrastructure for this, Sanity Only testing. Hopely Jason will help us to test this one.
Comment 49 Jason Roysdon 2010-06-01 12:27:12 EDT
Yes, I have RHEL6Beta downloaded and have been testing in a VM.  I'll just need to do some LVM work to install it natively on my host and get my client's permission to test on their EAP-FAST network.
Comment 50 Jason Roysdon 2010-06-16 18:31:34 EDT
I have my client's permission to test this on their EAP-FAST network and access to their Cisco AP and RADIUS server (Cisco ACS) which it passes authentication to.

However, I do not see EAP-FAST as an option in Network Manager.  Right-clicking on NetworkManager icon, Edit Connections - Wireless (tab) - Add - Wireless Security (tab) - Security: WPA & WPA2 Enterprise

At this point the next step is to set the Authentication type.  The drop-down box supports TLS, LEAP, Tunneled TLS (TTLS), and Protected EAP (PEAP), but there is no EAT-FAST option.

$ rpm -q openssl
openssl-1.0.0-0.19.beta4.el6.i686
$ rpm -qa | grep -i network
NetworkManager-0.7.997-1.el6.i686
NetworkManager-glib-0.7.997-1.el6.i686
NetworkManager-gnome-0.7.997-1.el6.i686
$ rpm -qa | grep wpa
wpa_supplicant-0.6.8-9.el6.i686
$ rpm -q kernel
kernel-2.6.32-19.el6.i686

$ uname -a
Linux rhel6b1 2.6.32-19.el6.i686 #1 SMP Tue Mar 9 18:10:40 EST 2010 i686 i686 i386 GNU/Linux

Are we sure that EAP-FAST is now enabled in NetworkManager?
Comment 51 Miroslav Vadkerti 2010-06-17 00:08:57 EDT
Jason, according to bug 209339 which is still assigned NM hasn't got EAP-FAST support yet. Setting needinfo on Dan Williams.
Comment 52 Miroslav Vadkerti 2010-06-25 08:16:07 EDT
Dan, openssl seems to be supporting EAP-FAST now but NM does not.
Comment 53 Miroslav Vadkerti 2010-09-15 08:48:56 EDT
Dan, could you please answer comment #52?
Comment 54 releng-rhel@redhat.com 2010-11-15 09:33:51 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.