Bug 428190 - [RFE] CRM - 1287306 - management of symbolic links through configuration channels
[RFE] CRM - 1287306 - management of symbolic links through configuration chan...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Red Hat Satellite QA List
: FutureFeature, Triaged
: 545988 (view as bug list)
Depends On:
Blocks: sat540-cfg-symlinks
  Show dependency treegraph
 
Reported: 2008-01-09 15:41 EST by Issue Tracker
Modified: 2011-08-08 10:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-01-09 15:41:45 EST
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-01-09 15:41:47 EST
Currently it is not possible to manage symbolic links through configuration channels. Symbolic links are used in a number of ways to configure Linux machines, including the service configuration in /etc/rc?.d and the alternatives system. It would be highly useful to be able to deploy symbolic links in the same way as other configuration files so that systems can be fully managed from within Satellite.
This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 114169
Comment 3 Joshua Roys 2009-08-28 10:47:24 EDT
Hello,

I just submitted a patch to spacewalk-devel about this - please review.

Thanks,

Joshua Roys
Comment 6 Tomas Lestach 2010-09-01 05:00:45 EDT
*** Bug 545988 has been marked as a duplicate of this bug. ***
Comment 9 Pavel Novotny 2010-10-04 04:12:16 EDT
Verified, this feature is introduced in Sat 5.4 and meets all requirements.

Reply to comment #5: this feature *requires* updated client tools packages (rhncfg, rhncfg-client, rhncfg-management) at least to version 5.9.27-1.el5 and newer.
Comment 10 Tomas Lestach 2010-10-26 10:43:57 EDT
I created a new symlink file and successfully deployed it. I also imported an existing symlink from the registered system into the sandbox and successfully deployed it.

Note: Setting of permissions for symlink files is not supported. This is correct as man chmod (coreutils-5.97-23.el5_4.2) says:
   chmod never changes the permissions of symbolic links;  the  chmod  system
   call  cannot  change  their  permissions.  This is not a problem since the
   permissions of symbolic links are never used.

STAGE VALIDATED on Satellite-5.4.0-RHEL5-re20101015.0
Comment 11 Clifford Perry 2010-10-28 10:45:10 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.