Bug 428203 - Network Error: There was an error configuring your network interface
Network Error: There was an error configuring your network interface
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
hotissue
: Reopened
Depends On:
Blocks: F9Alpha
  Show dependency treegraph
 
Reported: 2008-01-09 16:55 EST by Orion Poplawski
Modified: 2008-01-28 13:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 13:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-01-09 16:55:14 EST
Description of problem:

Trying to do PXE install of today's rawhide.  Get box:

Network Error
There was an error configuring your network interface

VT3 messages:
ERROR : common_tables.c(894): non-null target for new_hash_table.
ERROR : option_space_encapsulate: option space agent does not exist, but is
configured.
INFO  : DHCPREQUEST on eth0 to 255.255.255.255 port 67 interval 6
INFO  : DHCPOFFER from 192.168.0.8
ERROR : option_space_encapsulate: option space agent does not exist, but is
configured.
INFO  : DHCPREQUEST on eth0 to 255.255.255.255 port 67
INFO  : DHCPACK from 192.168.0.8
INFO  : bound to 192.168.0.74 -- renewal in 5413 seconds.
ERROR : add: failed - 17: Netlink Error (errno = File exists)
ERROR : nic_configure: failed to add routes.
INFO  : result of pumpSetupInterface is DHCP configuration failed - 1 Operation
not permitted.
Comment 1 Orion Poplawski 2008-01-14 16:33:30 EST
Still a problem with 20080114.  Two different systems so it seems a general
issue.  Makes rawhide uninstallable for me.
Comment 2 David Cantrell 2008-01-14 20:08:50 EST
Try tomorrow's rawhide.  I spent all day today hacking on the problems you
describe.  I think I've taken care of pretty much all of them.

Thanks.
Comment 3 Orion Poplawski 2008-01-15 11:54:58 EST
Today I get:

loader received SIGSEGV! Backtrace:
/sbin/loader(loaderSegvHandler+0xa0)
/lib/libdhcp4client-4.0.so.0(state_selecting+0x60)
                            (process_outstanding_timeouts+0xf8)
                            (dhcpv4_client+0x1777)
/lib/libdhcp-1.99.so.1(do_dhcpv4+0x3c)
                      (dhcp_nic+0x3a)
                      (pumpDhcpClassRun+0x127)
/sbin/loader(doDhcp+0x12a)
            (configureTCPIP+0x9b8)
            (readNetConfig+0x3bd)


On vt3, a couple of:
CRITICAL: Internal inconsistency: storage value has not been initialized to zero
(from tables.c) (various line numbers: 1267, 1227)

lots of
ERROR: tables.c(): non-null target for new_hash_table.  (lines
1232,1234,1272,1274,1055,1057,1101,1103,1147,1149,1188,1190,1232,1234,1272,1274)
Comment 4 Orion Poplawski 2008-01-22 11:23:35 EST
With today (20080122), get backtrace:

/sbin/loader(loaderSegvHandler+0xa0)
/lib/libdhcp4client-4.0.so.0(make_discover+0x4c)
                            (state_init+0x2f)
                            (state_selecting_timeouts+0xf8)
                            (dhcpv4_client+0x1777)
/lib/libdhcp-1.99.so.1(do_dhcpv4+0x3c)
                      (dhcp_nic+0x3a)
                      (pumpDhcpClassRun+0x127)
/sbin/loader(doDhcp+0x12a)
            (configureTCPIP+0x9b8)
            (readNetConfig+0x3bd)

It appears to keep retrying to getdhpc address.  On VT3 see the DHCPOFFER from
the server, but then lots of tables.c non-null target for new_hash_table and:

CRITICAL: Internal inconsistency: storage value has not been initialized to zero
(from tables.c:1227 and 1267).
Comment 5 David Cantrell 2008-01-22 22:30:04 EST
The non-null errors you're seeing are a problem with libdhcp4client.  They are a
different problem from the original.  I'm closing this bug as fixed in rawhide
because we're starting to get multiple issues here.

I have fixed the problem you describe in comment #4 (the fix will be in the
dhcp-4.0.0-6.fc9 package).  If it happens again, please file a new bug.

Thanks.
Comment 6 Orion Poplawski 2008-01-23 11:27:49 EST
Re-opening because I'm back to the same situation as that in the opening
comment, minus the "non-null" and "option_space_encapsulate" messages.

INFO  : DHCPREQUEST on eth0 to 255.255.255.255 port 67 interval 6
INFO  : DHCPOFFER from 192.168.0.8
INFO  : DHCPREQUEST on eth0 to 255.255.255.255 port 67
INFO  : DHCPACK from 192.168.0.8
INFO  : bound to 192.168.0.74 -- renewal in 5413 seconds.
ERROR : add: failed - 17: Netlink Error (errno = File exists)
ERROR : nic_configure: failed to add routes.
INFO  : result of pumpSetupInterface is DHCP configuration failed - 1 Operation
not permitted.
Comment 7 Orion Poplawski 2008-01-28 13:28:45 EST
Fixed now.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.