Bug 428204 - cpuspeed status reports 'cpuspeed dead but subsys locked'
cpuspeed status reports 'cpuspeed dead but subsys locked'
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 16:56 EST by Geoff Gustafson
Modified: 2009-04-15 17:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 17:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2008-01-09 16:56:31 EST
After installing RHEL4.6 on a Bensley/ClovertownG0 SDV, the first time I try to
run "service cpuspeed status" it reports "cpuspeed dead but subsys locked". I
can confirm there is a /var/lock/subsys/cpuspeed file present but no
/var/run/cpuspeed.pid.

I saw this after installing both x86_64 and i386 versions.

I am able to run "service cpuspeed stop" and "service cpuspeed start" and it
corrects itself.

After that, I do _not_ see the problem again on reboot.
Comment 1 Geoff Gustafson 2008-01-10 17:07:05 EST
Just reproduced the same issue on a radically different mobile Montevina SDV. So
I think this is probably a fairly generic problem with RHEL4.6.
Comment 2 Jarod Wilson 2008-02-14 15:06:01 EST
Hrm, been unable to reproduce this as of yet, but then I've only tried on two
systems, and one of them doesn't support freq scaling at all (which I didn't
realize until after installing, of course). If you can reproduce this again, can
you grab me /var/log/messages and dmesg output?

Oh, hrm, just noticed that I was doing 4.7 installs too, not 4.6... I don't
think cpuspeed in the 4.7 trees has changed yet though. Could be kernel-related
too though. Ugh. Will try again with 4.6 myself too.
Comment 3 Jarod Wilson 2008-02-19 16:25:02 EST
Just installed 4.6 on a box, but apparently, not even the newest rhel4 beta
kernel supports freq scaling on this box (it works in rhel5 and fedora). I lose
again...
Comment 4 Geoff Gustafson 2008-05-21 15:48:32 EDT
I haven't noticed this for a while, I'll try to keep my eyes open the next time
I do a 4.6/4.7 install. Maybe John or I can try doing a 4.7 install on the
Montevina and perhaps Bensley.
Comment 5 Jarod Wilson 2008-08-21 09:48:12 EDT
Geoff and/or John, have either of you been able to reproduce this problem w/4.7?
Comment 6 Jarod Wilson 2009-04-15 17:07:45 EDT
Since we've apparently not been able to hit this in over a year, I'm going to just go ahead and close it out.

Note You need to log in before you can comment on or make changes to this bug.