Bug 428206 - Eclipse fails after splash screen dialog says: "An error has occurred"
Eclipse fails after splash screen dialog says: "An error has occurred"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 17:14 EST by Leo Lopes
Modified: 2008-01-15 15:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 15:08:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse startup log file (174.88 KB, text/plain)
2008-01-09 17:14 EST, Leo Lopes
no flags Details
Output of the DebuggingEclipseProblems script (2.23 KB, text/plain)
2008-01-09 18:12 EST, Leo Lopes
no flags Details

  None (edit)
Description Leo Lopes 2008-01-09 17:14:40 EST
Description of problem: After splash screen, a dialog saying: "An error has
occurred. See the log file /home/myhome/workspace/.metadata/.log.".

Version-Release number of selected component (if applicable): 3.2.2. Details:

[~]$ rpm -qa | grep eclipse
eclipse-platform-3.2.2-15.fc7
eclipse-jdt-3.2.2-15.fc7
eclipse-ecj-3.2.2-15.fc7
eclipse-rcp-3.2.2-15.fc7
eclipse-pydev-1.3.1-5.fc7


How reproducible: Allways

Steps to Reproduce:
1. rm -Rf ~/.eclipse workspace; eclipse -clean
  
Actual results: Splash screen appears, then error dialog. Contents of log file
are below

Expected results: Eclipse should run


Additional info: 2 possibly important pieces of additional information:

1. Just upgraded to Fedora 7.
2. The log file (attached) speaks of a bunch of missing bundles.

Also get the following GTK Theme errors:
/home/myhome/.themes/WarmGorilla-GTK2/gtk-2.0/iconrc:39: Unable to locate image
file in pixmap_path: "WarmGorilla_stock_goto-bottom.svg"
/home/myhome/.themes/WarmGorilla-GTK2/gtk-2.0/iconrc:40: Unable to locate image
file in pixmap_path: "WarmGorilla_stock_goto-first.svg"
/home/myhome/.themes/WarmGorilla-GTK2/gtk-2.0/iconrc:41: Unable to locate image
file in pixmap_path: "WarmGorilla_stock_goto-last.svg"
/home/myhome/.themes/WarmGorilla-GTK2/gtk-2.0/iconrc:42: Unable to locate image
file in pixmap_path: "WarmGorilla_stock_goto-top.svg"
/home/myhome/.themes/WarmGorilla-GTK2/gtk-2.0/iconrc:101: Unable to locate image
file in pixmap_path: "WarmGorilla_stock_reset.svg"
Comment 1 Leo Lopes 2008-01-09 17:14:40 EST
Created attachment 291209 [details]
eclipse startup log file
Comment 2 Andrew Overholt 2008-01-09 18:00:34 EST
Please attach the output of the shell snippet listed here:

http://fedoraproject.org/wiki/DebuggingEclipseProblems
Comment 3 Leo Lopes 2008-01-09 18:12:18 EST
Created attachment 291216 [details]
Output of the DebuggingEclipseProblems script
Comment 4 Andrew Overholt 2008-01-15 10:32:22 EST
:)  I looks like you have some problems.  I don't know how that could have
happened.  Did you abort a yum transaction (install, upgrade, etc.) at some
point?  Anyway, I recommend re-installing libswt3-gtk2 and the rest of the RPMs
coming from the eclipse SRPM.  Let me know if that works for you.
Comment 5 Leo Lopes 2008-01-15 11:56:42 EST
Thanks for the suggestion. I already have libswt3-gtk2-3.2.2-15.fc7.i386.rpm
installed. What are the packages you are referring to from the .spec? I looked
at the spec online and there are a bunch of packages there which seem specific,
while others seem general. Here is what I have that says eclipse in it:

[root@mybox ~]# for rpm in `rpm -qa`; do echo -n $rpm; rpm -qi $rpm | grep -qsi
eclipse; echo :$?; done | grep :0
eclipse-platform-3.2.2-15.fc7:0
libgcj-src-4.1.2-27.fc7:0
lucene-devel-1.4.3-1jpp.18:0
eclipse-jdt-3.2.2-15.fc7:0
eclipse-ecj-3.2.2-15.fc7:0
eclipse-rcp-3.2.2-15.fc7:0
libswt3-gtk2-3.2.2-15.fc7:0
eclipse-pydev-1.3.1-5.fc7:0

This may be part of the reason why I have problems: at some point, when I had a
previous Fedora version, I had a jpackage version of Eclipse. Since jpackage was
giving me problems, at some point I uninstalled all packages that had jpp but
not fc in them, disabled the jpackage repository, and installed the Fedora
versions of everything I really cared about. Does that help?
Comment 6 Andrew Overholt 2008-01-15 12:12:37 EST
I don't know what you mean by "specific" and "general".  Try removing all
existing eclipse RPMs and re-installing them using yum.
Comment 7 Leo Lopes 2008-01-15 15:08:34 EST
Reinstall fixed everything. Thanks for your help. Each package installed and
removed was exactly the same version. So it is hard to find a root cause.

Note You need to log in before you can comment on or make changes to this bug.