This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 428214 - Occassionally stat cmnd cannot find an existing nfs file
Occassionally stat cmnd cannot find an existing nfs file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 18:09 EST by Sev Binello
Modified: 2008-09-24 04:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.9-67.0.4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 04:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sev Binello 2008-01-09 18:09:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.13pre) Gecko/20071018 Red Hat/1.0.9-6.el4 SeaMonkey/1.0.9

Description of problem:
When running the stat commands continuously on an existing file, 
from a WS4 machine, to a filesystem mounted from WS3.
It occassionally cannot find the file, and we get 
stat: cannot stat `/cfs/e/LoggerData/run_fy08/09503/RHIC/Instrumentation/10HzDX-IR6/2008-01-01.1412.sdds': No such file or directory

Even though it found it before.
This only happens when stat'ing from a ws4 machine to a file on ws3.
Ws3 to ws3 works, ws4 to ws4 works, local files work.
This is an issue because it crops up when doing recursive copies,
it will miss files that actually exit.



Version-Release number of selected component (if applicable):
coreutils-5.2.1-31.6

How reproducible:
Always


Steps to Reproduce:
1.Go on a ws4 machine
2.Stat a file on a ws3 machine
3.Put this in a loop

Actual Results:
after some time, there will be a msg that it cannot stat the file

Expected Results:
should always see it

Additional info:
Not sure if this is a stat cmnd problem, or nfs or something else
But I figure I'll start here.


Simly put stat in a repeat 
repeat 50000  stat "some file"

stat: cannot stat `/cfs/e/LoggerData/run_fy08/09503/RHIC/Instrumentation/10HzDX-IR6/2008-01-01.1412.sdds': No such file or directory
Comment 1 RHEL Product and Program Management 2008-09-05 13:05:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Kamil Dudka 2008-09-22 10:08:13 EDT
I was unable to reproduce this bug. I installed RHEL 3.9 WS and RHEL 4.5 WS (both i386) into Xen (fully virtualized hosts).

My exports on RHEL 3.9 WS machine:
# cat /etc/exports
/var xen65

Mount on RHEL 4.5 WS machine and check for bug:
# cd /mnt
# mkdir var-WS3
# mount -o ro -t nfs xen20:/var var-WS3
# while clear && stat var-WS3/yp/nicknames; do echo ok...; done
It can run for hours.

Coreutils version on RHEL 4.5 WS:
# rpm -q coreutils
coreutils-5.2.1-31.6

Could you please post your exports and mounts? strace output of failing stats would be also helpful. Thanks!
Comment 3 Sev Binello 2008-09-23 13:58:19 EDT
We were able to get around this problem when we upgraded
RHWS4U5(kenel level:  2.6.9-55.0.9)-to-kernel level: RHWS4U6 (kernel level: 2.6.9-67.0.4)
Comment 4 Ondrej Vasik 2008-09-24 04:15:49 EDT
Ok, thanks for informations, it really looks more like kernel issue than coreutils one. So closing CURRENTRELEASE with changed component to kernel...

Note You need to log in before you can comment on or make changes to this bug.