Bug 428222 - builtins man page missing section on conditional expressions
builtins man page missing section on conditional expressions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Janousek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 19:20 EST by Mikel Ward
Modified: 2008-02-04 09:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 09:13:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-01-09 19:20:37 EST
Some man pages refer to bash builtins (usually but not always including read and
test).

The documentation for test doesn't mention common things like the -f, -d, or -L
flags.  It refers to a non-existent section called "CONDITIONAL EXPRESSIONS".

If you can't see the man page I'm talking about, just try "man builtins".

$ rpm -q bash
bash-3.2-18.fc8
Comment 1 Tomas Janousek 2008-01-21 08:38:31 EST
The text in the builtins.1 manpage is included from the bash.1 manpage, so it
refers to the section in the bash manpage. I don't think it's viable to mention
that the section is in the bash manpage, not in the builtins one, because the
very same text would have to be in the bash manpage.
Comment 2 Mikel Ward 2008-01-21 15:31:54 EST
I was thinking we either statically include that section of text from the bash
man page, dynamically include it, or better still, re-write the section on the
test builtin to include it.
Comment 3 Tomas Janousek 2008-02-04 09:13:23 EST
I don't think it's worth the effort.

Note You need to log in before you can comment on or make changes to this bug.