Bug 428240 - TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'
TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object ha...
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 03:35 EST by Vladimir
Modified: 2008-01-10 09:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 09:17:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch' (1.63 KB, application/octet-stream)
2008-01-10 03:35 EST, Vladimir
no flags Details

  None (edit)
Description Vladimir 2008-01-10 03:35:14 EST
Description of problem:

When The install/remove packuge is being started the error shows:

An unhandled exception has occurred.  This is most likely a bug.  Please save
the crash dump and file a detailed bug report against pirut at
https://bugzilla.redhat.com/bugzilla

Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType'
object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x10d7440>
commands: None
opts: None
Comment 1 Vladimir 2008-01-10 03:35:14 EST
Created attachment 291244 [details]
TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'
Comment 2 James Antill 2008-01-10 09:17:21 EST
 How did you manage to update to a none latest package?


*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.