Bug 428283 - Rotate does not work with compiz
Summary: Rotate does not work with compiz
Status: CLOSED DUPLICATE of bug 365951
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-10 14:08 UTC by Tim Niemueller
Modified: 2018-04-11 08:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 16:35:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.65 KB, application/octet-stream)
2008-02-08 18:27 UTC, Tim Niemueller
no flags Details
Xorg.0.log with existing xorg.conf (102.16 KB, text/plain)
2008-02-08 18:27 UTC, Tim Niemueller
no flags Details
Xorg.0.log without any xorg.conf (86.36 KB, text/plain)
2008-02-08 18:28 UTC, Tim Niemueller
no flags Details
xorg.conf (913 bytes, text/plain)
2008-02-08 23:52 UTC, Matěj Cepl
no flags Details
Xorg.setup.log (1.83 KB, text/plain)
2008-02-08 23:53 UTC, Matěj Cepl
no flags Details
Xorg.0.log (66.10 KB, text/plain)
2008-02-08 23:54 UTC, Matěj Cepl
no flags Details
Xorg.20.log (143.35 KB, text/plain)
2008-02-08 23:54 UTC, Matěj Cepl
no flags Details
Xorg.21.log (67.24 KB, text/plain)
2008-02-08 23:54 UTC, Matěj Cepl
no flags Details

Description Tim Niemueller 2008-01-10 14:08:55 UTC
Description of problem:
While compiz is enabled the screen cannot be rotated. It rotates the screen, but
then the desktop does not adapt, meaning that it still has the old resolution
cutting of parts on the right and not extending over the full height.

The desktop does not react to input any longer (mouse, keyboard). However,
pressing the "Print" button (tried to take a snapshot but failed) makes the
mouse cursor switch to busy for a short moment.

Switching to a VT and back blanks the screen to black, mouse cursor is visible.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-7.fc8
compiz-0.6.2-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Enable desktop effects
2. rotate screen using the screen resolution preferences
3. See rotate fail

Alternative:
1. Rotate screen (while desktop effects are disabled)
2. Enable rotate screen
3. Screen freezes instantly.
  
Actual results:
Desktop freezes and has to be killed with Ctrl-Alt-Backspace.

Expected results:
Screen should have been rotated with desktop effects enabled.

Additional info:
Smolt profile available at
http://www.smolts.org/show?UUID=7bdea940-701e-4cbe-9ad1-bd44d276932a

Comment 1 Matěj Cepl 2008-01-31 17:11:18 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Tim Niemueller 2008-02-08 18:27:09 UTC
Created attachment 294391 [details]
xorg.conf

Comment 3 Tim Niemueller 2008-02-08 18:27:43 UTC
Created attachment 294392 [details]
Xorg.0.log with existing xorg.conf

Comment 4 Tim Niemueller 2008-02-08 18:28:09 UTC
Created attachment 294393 [details]
Xorg.0.log without any xorg.conf

Comment 5 Tim Niemueller 2008-02-08 18:29:06 UTC
Added the requested log and config files. The problem remains with the latest
updates from today installed (not updates-testing though, let me know if
anything relevant is there).

Comment 6 Matěj Cepl 2008-02-08 23:51:46 UTC
I have updates-testing here and I can fully reproduce it here. Also, when
crashing (I have even User Switching enabled and running out of the second users
desktop), it made such a mess with the system daemons, that I was not able to
make it work again (neither HAL, d-bus, NM, or any other important daemon run
and they couldn't be restarted).

Comment 7 Matěj Cepl 2008-02-08 23:52:17 UTC
Created attachment 294432 [details]
xorg.conf

Comment 8 Matěj Cepl 2008-02-08 23:53:59 UTC
Created attachment 294433 [details]
Xorg.setup.log

Comment 9 Matěj Cepl 2008-02-08 23:54:09 UTC
Created attachment 294434 [details]
Xorg.0.log

Comment 10 Matěj Cepl 2008-02-08 23:54:24 UTC
Created attachment 294435 [details]
Xorg.20.log

Comment 11 Matěj Cepl 2008-02-08 23:54:34 UTC
Created attachment 294436 [details]
Xorg.21.log

Comment 12 Matěj Cepl 2008-02-13 16:35:17 UTC

*** This bug has been marked as a duplicate of 365951 ***


Note You need to log in before you can comment on or make changes to this bug.