Bug 428284 - chown and chgrp commands do not work with ksh
chown and chgrp commands do not work with ksh
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.1
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 09:28 EST by Christoph Szeppek
Modified: 2008-01-11 01:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 01:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Szeppek 2008-01-10 09:28:32 EST
Description of problem:
ksh fails when executing "chgrp" oder "chown" with reason: Operation not permitted.

Version-Release number of selected component (if applicable):
ksh-20060214-1.4

How reproducible:
always

Steps to Reproduce:
1. run ksh
2. Try to change a file's user or group
  
Actual results:
- An operation-not-permitted-error occurs.
- The file's user / group does not change.

Expected results:
- No error.
- The file's user / group should be set to the specified one.

Additional info:
- The same error occurs on our RHEL 4 AS machines.
- It is probably architecture independend.
Comment 1 Tomas Smetana 2008-01-10 09:44:04 EST
Does the same work in bash (or any other shell)? On my system everything seems
to work as expected.

Could you also post output of the 'id' command under the user you have
encountered the bug and 'ls -l' of the file you want to change?

Thanks.
Comment 2 Christoph Szeppek 2008-01-10 12:37:54 EST
I did the tests with as a user with insufficient permissions.
The test works as expected when run as a user with proper permissions.

I still have a problem running a specific shell script that only appears with
ksh but not with pdksh.
It gives random errors not to be able to run cp, chmod and chgrp and did not
appear before the update to version 20060214-1.4.

So what I described is not a bug. We will investigate the problem with the script.

Thanks.
Comment 3 Tomas Smetana 2008-01-11 01:52:31 EST
OK.  I'll close this bugzilla.  Please open a new one with proper
title/description when you locate the problem with the script.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.